Save calculated ReplayGain when writing file metadata

Bug #687293 reported by Vittorio Colao on 2010-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Uwe Klotz
1.10
Medium
Unassigned
1.11
Medium
Unassigned

Bug Description

One of the features which came from features_library branch is the possibility of editing track properties and save them to file tags.
On the other hand, features_replaygain implements "replaygain_track_gain" tag reading and calculates it for tracks without such tag. Since such features went implemented into two different branches, Mixxx is able to read and calculate ReplayGain but not to store it in tags.
It would be handy if Mixxx was able to store ReplayGain value into "replaygain_track_gain" field.

RAFFI TEA (raffitea) wrote :

Good catch. This should be easy to implement in the class AudioTagger.

RJ Skerry-Ryan (rryan) on 2011-03-20
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Wishlist
summary: - Mixxx 1.9beta1 does not save ReplayGain value in file tags
+ Save calculated ReplayGain when writing file metadata
tags: added: easy weekend
RAFFI TEA (raffitea) on 2011-03-23
Changed in mixxx:
assignee: nobody → RAFFI TEA (raffitea)
milestone: none → 1.10.0
status: Confirmed → In Progress
RJ Skerry-Ryan (rryan) wrote :

Tobias -- are you working on this one or can we release it to the wishlist pool?

Daniel Schürmann (daschuer) wrote :

Please note also Bug #840860 "reload track metadata changes gain of a playing track"

RAFFI TEA (raffitea) wrote :

I can provide a fix by today

RAFFI TEA (raffitea) wrote :

I do not follow this wishlist bug for 1.10 because of Bug #728197.
Writing metadata to ID3 file will be deactivated for Mixxx 1.10 because you may ruin your tracks.

Changed in mixxx:
milestone: 1.10.0 → none

If this is implemented, please make it optional so as not to risk damaging the tracks.

Hi Cole,

We would never default to touching your files for that very reason! We
would only do it on an opt-in basis.

On Mon, May 27, 2013 at 4:37 PM, Cole Johnson
<email address hidden>wrote:

> If this is implemented, please make it optional so as not to risk
> damaging the tracks.
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/687293
>
> Title:
> Save calculated ReplayGain when writing file metadata
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/687293/+subscriptions
>

RJ Skerry-Ryan (rryan) wrote :

Bumping this back into the pool, Tobias. Please re-assign if you'd still like to work on it!

Changed in mixxx:
status: In Progress → Triaged
assignee: RAFFI TEA (raffitea) → nobody
Uwe Klotz (uklotzde) wrote :

Solution is part of this PR that re-enables tag writing:
https://github.com/mixxxdj/mixxx/pull/592

Changed in mixxx:
assignee: nobody → Uwe Klotz (uklotzde)
Uwe Klotz (uklotzde) on 2015-08-17
Changed in mixxx:
status: Triaged → In Progress
Uwe Klotz (uklotzde) wrote :
Uwe Klotz (uklotzde) on 2017-12-05
Changed in mixxx:
milestone: none → 2.1.0
Uwe Klotz (uklotzde) on 2017-12-10
Changed in mixxx:
status: In Progress → Fix Committed
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers