Mixxx fails to build on non-x86/x64 archs on Debian

Bug #683029 reported by Alessio Treglia on 2010-11-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Undecided
Alessio Treglia
mixxx (Debian)
Fix Released
Unknown

Bug Description

Hi,

on Debian we've applied the attached patch to make mixxx 1.8.1 able to build on alpha architectures successfully.

Thanks in advance.

Related branches

Alessio Treglia (quadrispro) wrote :
Changed in mixxx (Debian):
status: Unknown → Fix Released

Fix committed in r2697 of the 1.8 branch

Changed in mixxx:
assignee: nobody → Alessio Treglia (quadrispro)
status: New → Fix Committed
Alessio Treglia (quadrispro) wrote :

There is a regression in Mixxx 1.9.0.

Plus, it doesn't build on mips,mipsel,s390,armel,hppa,ia64,sparc,powerpc anymore.

With the attached patch the issue is solved.

Changed in mixxx:
status: Fix Committed → Confirmed
assignee: Alessio Treglia (quadrispro) → nobody
tags: added: alpha amd64 armel debian hppa ia64 mips mipsel powerpc regression s390 sparc
Alessio Treglia (quadrispro) wrote :

'AMD64' is not recognized, I had to replace it with 'amd64'.

summary: - Mixxx 1.8.1 fails to build on Debian alpha
+ Mixxx fails to build on non-x86/x64 archs on Debian

'AMD64' is what Windows uses and since Python is case-sensitive, I've added both and committed the patch to r2745 of the 1.9 branch and r2649 of trunk so hopefully it won't regress again. Thanks for helping us out with this! (I wonder how well Mixxx runs on these other architectures...) And if I assign you to the bug, you get the karma credit, FWIW. :)

Changed in mixxx:
status: Confirmed → Fix Committed
assignee: nobody → Alessio Treglia (quadrispro)
Alessio Treglia (quadrispro) wrote :

Thanks for the quick reply!

Now I'm working to make mixxx able to run on Debian kFreeBSD too, I'll let you know!

Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.