Mixxx 1.9: ReplayGain default value is too low.

Bug #681439 reported by Vittorio Colao on 2010-11-25
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Undecided
Vittorio Colao

Bug Description

Freshly introduced ReplayGain support defaults its initial gain value (InitialReplayGainBoost) to 6.
Problems are that

* Volume is too quiet.
* Corresponding waveform is too small to work with it.

I am submitting a patch which defaults InitialBoost to 12. Moreover, it introduces a solution to Bug #677626 ( lp:mixxx does not set InitialReplayGainBoost in mixxx.cfg ).

Vittorio Colao (l0rdt) wrote :
Changed in mixxx:
assignee: nobody → Vittorio Colao (l0rdt)
status: New → Confirmed
RJ Skerry-Ryan (rryan) wrote :

Hmm, setting to 12 might be too high -- now some songs are replay-gained such that they clip for me. Even a setting of 8 causes clipping for me on a variety of dance music I have. I actually think 6dB looks fine waveform-wise. I think the people who thought it looked too small may have been affected by the 0dB default bug.

Vittorio Colao (l0rdt) wrote :

I can confirm that waverform is wise enough with an initial gain of 6dB and for all tracks I could find.
Hence, it remains to apply patch to solve such 0db default bug:
( https://bugs.launchpad.net/mixxx/+bug/677626/+attachment/1738635/+files/InitialReplayGainBoostConfigValue.diff ).

Vittorio Colao (l0rdt) on 2010-11-29
Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-10
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers