Support 45 rpm vinyl mode

Bug #672758 reported by RAFFI TEA on 2010-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Owen Williams
1.10
Wishlist
Owen Williams

Bug Description

Since Owen's branch contains xwax 0.8 it is possible to support 45 rpm.

Related branches

RAFFI TEA (raffitea) on 2010-11-08
Changed in mixxx:
importance: Undecided → Wishlist
Bill Good (bkgood) on 2010-11-18
Changed in mixxx:
status: New → Confirmed
RAFFI TEA (raffitea) wrote :

I assign Owen the bug. Maybe he can realize an implementation (if he likes to).

Changed in mixxx:
assignee: nobody → Owen Williams (ywwg)
Owen Williams (ywwg) wrote :

yeah this is an easy thing to do. Since this is really just a preference change, I'll also support different types of vinyl on each deck.

Changed in mixxx:
status: Confirmed → In Progress

Wow diff vinyls on each deck would be awesome...and a world first! I don't think that's ever been done!

RAFFI TEA (raffitea) wrote :

Thanks Owen!

45 RPM might be very useful especially in 'pass-through' mode.

Owen Williams (ywwg) wrote :

Pass-through mode literally passes through the input audio, so it's actually a separate feature from vinyl control. ie, even if it's the mac app store version with no xwax, input passthrough will still work. As such, there's no need to have special support for 45 vs 33 passthrough.

I'm not sure different vinyl is a first... I swear I've seen serato djs using side A on one deck and side B on the other.

But it would be a fun demo to have traktor on one and serato on the other :)

RAFFI TEA (raffitea) on 2011-04-17
Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers