Support single deck vinyl control

Bug #661473 reported by RJ Skerry-Ryan on 2010-10-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Owen Williams

Bug Description

Vinyl control is great with 2 decks, but we should allow the use of one turntable and dynamically switch which player is being controlled.

RJ Skerry-Ryan (rryan) on 2010-10-15
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Wishlist
assignee: nobody → Owen Williams (ywwg)
Owen Williams (ywwg) wrote :

fixed in features_xwax2

Changed in mixxx:
status: Confirmed → In Progress
Bill Good (bkgood) wrote :

This is done, right? (working two decks with one vinyl input works for me, one just has to ctrl+<key> the different decks on and off as they please)

Changed in mixxx:
milestone: none → 1.10.0
status: In Progress → Fix Committed

Owen showed me the trick to this -- you have to enable the single deck's
input to both vinyl input 1 and vinyl input 2 first. It'd be good if we
could make this not require this in the future (i.e. you only fill out 1
deck in the preferences and can hit 'Add another VC deck' if you have
another or something). Owen does this require extra code from your branch
or does it work in trunk?

On Fri, May 6, 2011 at 2:11 AM, Bill Good <email address hidden> wrote:

> This is done, right? (working two decks with one vinyl input works for
> me, one just has to ctrl+<key> the different decks on and off as they
> please)
>
> ** Changed in: mixxx
> Status: In Progress => Fix Committed
>
> ** Changed in: mixxx
> Milestone: None => 1.10.0
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/661473
>
> Title:
> Support single deck vinyl control
>

Owen Williams (ywwg) wrote :

No extra code needed, this works in trunk.

RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers