End of track warning

Bug #661443 reported by RJ Skerry-Ryan on 2010-10-15
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Thomas Vincent

Bug Description

We should have both a GUI widget that flashes at the end of the track (perhaps the waveform itself could flash) and a Control that indicates we are at the end of track. This could have a preference option for the number of seconds to start warning.

RJ Skerry-Ryan (rryan) on 2010-10-15
tags: added: easy weekend
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Wishlist
RJ Skerry-Ryan (rryan) on 2010-11-04
tags: added: waveform
Qifan Xi (khyew) wrote :

Working on this now with mentorship from Ryan. Progress at: lp:~khyew/mixxx/misc-features

RJ Skerry-Ryan (rryan) on 2011-03-23
Changed in mixxx:
assignee: nobody → Qifan Xi (khyew)
milestone: none → 1.10.0
status: Confirmed → In Progress
jus (jus) wrote :

Imho the main waveform should not be used for the end of track warning.

Why:
1. A track might be shorter then the default end of track warning time.
Same may use short tracks (e.g. drum samples to trigger with hotcues & midi pads). The EOT-warning may always be active then .
2. A loop overlay/Cue/Hotcue point may be active in the last part of a song making it hard to see if the EOT warning overlay has the the same/similar color.

So either the waveform overview or some of the tracks text display might be a better place for the EOT warning.

What do you guys think?

RAFFI TEA (raffitea) wrote :

Most DJ apps use the overview waveform for EOT.

RAFFI TEA (raffitea) wrote :

More precisely, the part of the overview waveform that is already played is colored in some different way. When it comes to the last 30 seconds the overview waveform blinks.

RJ Skerry-Ryan (rryan) wrote :

Moving to 1.11.0 since it will be part of the new waveform 2.0 efforts.

Changed in mixxx:
milestone: 1.10.0 → 1.11.0
RJ Skerry-Ryan (rryan) wrote :

Waveform-2.0 has an end-of-track indicator. Thanks for the work you did on this Qifan -- sorry it was deprecated :(

Changed in mixxx:
assignee: Qifan Xi (khyew) → Thomas Vincent (vrince)
jus (jus) wrote :

In latest r2754 of Waveform-2.0 the end of track warning with the last 30 seconds on the main waveform is NOT active in FIltered and Simple (GL) waveform mode, only in Filtered (GL) and FIltered (GLSL) waveform mode.
Tested with MacOSX 10.6.8

RJ Skerry-Ryan (rryan) on 2012-04-22
Changed in mixxx:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
jus (jus) on 2012-05-01
Changed in mixxx:
status: In Progress → Fix Committed
RJ Skerry-Ryan (rryan) on 2013-05-09
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers