Mixxx 1.8.0 > background color in library

Bug #642606 reported by hiend on 2010-09-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
High
RJ Skerry-Ryan

Bug Description

Ubuntu 10.10 beta. The background in library is white so the fonts are invisible, screenshot attached.

Related branches

hiend (hippako) wrote :
jus (jus) wrote :

Are you using revision latest revision (r2614) from http://bazaar.launchpad.net/~mixxxdevelopers/mixxx/release-1.8.x/revision/2614 by any chance?

RJ made some code changes ( some hours ago) allowing the library to by styled by CSS (QSS) as well. The QSS are not finished. I`ll push them to https://code.launchpad.net/~jus/mixxx/skins soon. This branch is in sync with trunk. Please report back than if it looks good for you on Linux.

On Sun, Sep 19, 2010 at 1:00 AM, jus <email address hidden> wrote:
> Are you using revision latest revision (r2614) from
> http://bazaar.launchpad.net/~mixxxdevelopers/mixxx/release-1.8.x/revision/2614
> by any chance?
>

Or is this with the 1.8.0 release candidate that's in Universe?

RJ Skerry-Ryan (rryan) wrote :

Confirmed using the current packaged version in the Ubuntu 10.10 repositories on a fresh install of 10.10 beta.

Changed in mixxx:
status: New → Confirmed
RJ Skerry-Ryan (rryan) wrote :

Even with lp:mixxx/1.8 the problem persists.

RJ Skerry-Ryan (rryan) wrote :

The system theme colors seem to over-ride what we set the library colors to be. If I change the system them to the vision-impaired high-contrast theme, the table items that were once white turn blue with the theme

RJ Skerry-Ryan (rryan) wrote :

Turns out this is a Qt 4.7.0 bug.

http://bugreports.qt.nokia.com/browse/QTBUG-13125
http://bugreports.qt.nokia.com/browse/QTBUG-13471

It's already fixed and is in 4.7.1. A workaround is possible with the right Qt styles, but it is really ugly.

RJ Skerry-Ryan (rryan) on 2010-09-21
Changed in mixxx:
milestone: none → 1.8.0
RJ Skerry-Ryan (rryan) wrote :

Added a workaround to the 1.8 branch that should detect if we are running Qt 4.7.0, and if so provide some hacked styles that should fix 99% of the visual issues. At least people will be able to read it.

Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
importance: Undecided → High
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers