Custom pixmaps for Loop/Cue/Hotcue look bad on top of loop overlay

Bug #640603 reported by jus on 2010-09-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
RJ Skerry-Ryan

Bug Description

Minor cosmetic issue, only one skin (Deere) is affected atm.

For Loop / Cue / Hotcue custom pixmaps ( defined by the <Pixmap></Pixmap> key) are supported in skin.xml. These Pixmaps are drawn on top of the existing vertical markers.

The vertical markers have triangles on top and bottom which make them visible against the background. The triangles are also shown if custom pixmaps are provided. The pixmaps must somewhat cover the triangles to make sense, but it looks very bad on top of the loop overlay.
See picture.

Solution would be to draw the triangles only if NO pixmap is provided (just like the text for hotcues, which is only drawn if we have no custom pixmap).

Related branches

jus (jus) wrote :
RJ Skerry-Ryan (rryan) on 2010-09-16
Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
milestone: none → 1.8.0
importance: Undecided → Low
status: New → Confirmed
RJ Skerry-Ryan (rryan) wrote :

Sounds fine, I made it so the triangles are not drawn if there is a custom pixmap provided. Thanks!

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers