Can not add tracks to AutoDJ

Bug #638159 reported by jus on 2010-09-14
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
High
RJ Skerry-Ryan
1.8
High
RJ Skerry-Ryan

Bug Description

Tested on Mac OSX with latest trunk

Regression: Drag and drop to AutoDJ does not work.
"Add to AutoDJ queue" context menue does nothing.

Related branches

RJ Skerry-Ryan (rryan) wrote :

My first hunch is that this is the new fs_deleted flag. The tables select() before the library scanner has marked the tracks as not fs_deleted, so they are blank. Another part of this bug is that the first crates and playlists are blank until you re-click on them in the sidebar (causing another select()). The AutoDJ pane doesn't re-select when you click on it so that is why it is staying blank.

RJ Skerry-Ryan (rryan) wrote :

Scratch that, fs_deleted isn't used for Playlists or Crates.

RJ Skerry-Ryan (rryan) wrote :

Actually, I was right. This was introduced in r2559 when fs_deleted was added to the DEFAULT_LIBRARYFILTER. The table models have select()'d before the scanner finishes, so the first thing they show is no tracks because all the tracks are set fs_deleted.

Changed in mixxx:
status: New → Confirmed
importance: Undecided → High

All the tracks are marked as need_verification when the scanner runs, they
should not be marked as fs_deleted ...
> Actually, I was right. This was introduced in r2559 when fs_deleted was
> added to the DEFAULT_LIBRARYFILTER. The table models have select()'d
> before the scanner finishes, so the first thing they show is no tracks
> because all the tracks are set fs_deleted.
>
> ** Also affects: mixxx/1.8
> Importance: Undecided
> Status: New
>
> ** Changed in: mixxx/1.8
> Status: New => Confirmed
>
> ** Changed in: mixxx
> Status: New => Confirmed
>
> ** Changed in: mixxx/1.8
> Importance: Undecided => High
>
> ** Changed in: mixxx
> Importance: Undecided => High
>
> ** Changed in: mixxx/1.8
> Milestone: None => 1.8.0
>
> --
> Can not add tracks to AutoDJ
> https://bugs.launchpad.net/bugs/638159
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.

RJ Skerry-Ryan (rryan) wrote :

Should be fixed now, the problem was related to fs_deleted but not what I predicted. fs_deleted needed to be added to the queries for CrateTableModel and PlaylistTableModel.

Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers