Keyboard shortcuts with Shift key not working

Bug #634493 reported by jus on 2010-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Undecided
Unassigned
1.7
Low
Unassigned
1.8
Low
Unassigned

Bug Description

Tested with 1.8 trunk + 1.7.2 on MacOS 10.5/10.6

If a keyboard shortcut is defined in Standard.kbd.cfg with a Shift modifier ( e.g. cue_set shift+d) the shortcut does not work at all.
I tried to use other modifier keys like CTRL or ALT with no luck.

Is there a way to see what key Mixxx receives?

RJ Skerry-Ryan (rryan) wrote :

Works for me on Linux. I made some keyboard changes to fix the 'Keyboard shortcuts seek through library' bug so it's possible that I screwed this up. The fact that this happens on 1.7.2 as well is strange, and points to a Qt issue.

You can see what key Mixxx receives in 1.8 by uncommenting lines 43, 68, and 133 in src/mixxxkeyboard.cpp.

jus (jus) wrote :

Thanks for the infos. Recompiled Mixxx to get these keyboard debug messages. See picture.

My sequence goes:
D
SHIFT+D

Mixxx receives:
D
SHIFT+additional characters
SHIFT+D

RJ Skerry-Ryan (rryan) wrote :

Shrug I can't reproduce this. Maybe OS X or Qt version specific thing ? I'm on Qt 4.6.2.

jus (jus) wrote :

Mehh, makes working wit the keyboard kinda impossible.
It is not QT versions specific for sure as it is the some problem with the official packages ( even 1.7).
Will test it on another Windows PC cause in a windows XP VM with Mac OSX host it wont work either.

Albert Santoni (gamegod) wrote :

I think it's a Mac OS X-only thing. QKeySequence doesn't seem to interpret strings like "Shift+[(native?) scan code]" properly on OS X.

If I change ConfigValueKbd to use a string representation for parsing and do the same for MixxxKeyboard, the problem goes away. Attached is a patch that does that.

RJ Skerry-Ryan (rryan) wrote :

This patch breaks the function button mappings with me. For example, F1 and F2 do not trigger rate_perm_up/down.

The log output when I hit F1 or F2 is:

Debug: [Main]: keyboard press: ""

Albert Santoni (gamegod) wrote :

Fixed in r2605. If keyboard shortcuts aren't working properly for anyone, please let us know ASAP. Thanks!

Changed in mixxx:
status: New → Fix Committed
jus (jus) wrote :

Still not working here on OSX 10.5 & 10.6 .
Tested Mixxx 1.8.0 (bzr r2607; built on: Sep 18 2010)

Loading a track in player 1 from the library,
then my sequence goes:
D
SHIFT+D

Mixx debug messages:
Debug: [Main]: press
Debug: [Main]: keyboard press: QKeySequence("D")
Debug: [Main]: keyboard press: QKeySequence("D")
Debug: [Main]: press
Debug: [Main]: keyboard press: QKeySequence("Shift+")
Debug: [Main]: press
Debug: [Main]: keyboard press: QKeySequence("Shift+")
Debug: [Main]: press
Debug: [Main]: keyboard press: QKeySequence("Shift+D")
Debug: [Main]: press
Debug: [Main]: keyboard press: QKeySequence("Shift+D")

Expected behaviour as defined in Standard.kbd.cfg
Playback
Set a cuepoint in track 1

Actual behaviour
Playback
Then nothing on track 1 - plus now the library steals focus. If you have a track beginning with an "D" in your library pressing "Shift+D" makes your cursor jump to this track ( "works" on the sidebar too).

Hey Jus,

Somehow I managed to fix it and then regress again. I think I've fixed
it one more time, can you please test again when you have a chance?

Thanks,
Albert

On Sat, Sep 18, 2010 at 3:39 AM, jus <email address hidden> wrote:
> Still not working here on OSX 10.5 & 10.6 .
> Tested Mixxx 1.8.0 (bzr r2607; built on: Sep 18 2010)
>
> Loading a track in player 1 from the library,
> then my sequence goes:
> D
> SHIFT+D
>
> Mixx debug messages:
> Debug: [Main]: press
> Debug: [Main]: keyboard press:  QKeySequence("D")
> Debug: [Main]: keyboard press:  QKeySequence("D")
> Debug: [Main]: press
> Debug: [Main]: keyboard press:  QKeySequence("Shift+")
> Debug: [Main]: press
> Debug: [Main]: keyboard press:  QKeySequence("Shift+")
> Debug: [Main]: press
> Debug: [Main]: keyboard press:  QKeySequence("Shift+D")
> Debug: [Main]: press
> Debug: [Main]: keyboard press:  QKeySequence("Shift+D")
>
> Expected behaviour as defined in Standard.kbd.cfg
> Playback
> Set a cuepoint in track 1
>
> Actual behaviour
> Playback
> Then nothing on track 1 - plus now the library steals focus. If you have a track beginning with an "D" in your library pressing "Shift+D" makes your cursor jump to this track ( "works" on the sidebar too).
>
> --
> Keyboard shortcuts with Shift key not working
> https://bugs.launchpad.net/bugs/634493
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
>

jus (jus) wrote :

All Shortcuts working now on OSX with Standard.kbd.cfg, thanks for the fix.

Sidenote (maybe it is a feature?):
Similar to #8 if your focus is on the library, one can navigate with shortcuts in the library if you hit e.g. SHIFT+K (which is not in Standard.kbd.cfg ) cursor will jump to a track who`s artists name beginning with the letter K.

Same if your focus is on the sidebar, SHIFT+I will take you to iTunes.

RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers