ASSERT in enginefilteriir.cpp when latency set high

Bug #629053 reported by jus on 2010-09-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
High
Unassigned
1.8
High
Unassigned
1.9
High
Unassigned

Bug Description

Mixxx 1.8.0 (bzr r2517; built on: Sep 2 2010 ; flags: hifieq vinylcontrol midiscript optimize=1 qdebug)
MacOSX 10.5.8

*Set your latency in Mixxx`preferences to the 2nd highest value ( for me 92ms)
*Play a track in 1st deck, you will notice a heavy distortion/lagging waveform
*Set your latency in Mixxx`preferences to the highest value ( for me 185ms)
*Load a track in 2nd deck, you will notice a steady clicking sound
*If Mixxx has not crashed yet, click play on 2nd deck

Fatal: []: ASSERT: "yv1[8]<100000 || yv1[8]>-100000" in file src/engine/enginefilteriir.cpp, line 59
Abort trap

1 minute screencast showing the problem
http://screenr.com/26r

RJ Skerry-Ryan (rryan) wrote :

Can't reproduce but that video evidence is hard to disagree with ;)

Changed in mixxx:
importance: Undecided → High
status: New → Confirmed
Bill Good (bkgood) on 2011-01-02
Changed in mixxx:
milestone: none → 1.9.0
RJ Skerry-Ryan (rryan) wrote :

Jus can you still repro with trunk?

Changed in mixxx:
milestone: 1.9.0 → 1.9.1
jus (jus) wrote :

No, i can not trigger an assert ASSERT like in the video, can`t get set latency this high anymore.
Now my max. latency is 42ms on the same hardware, it was 180+ms back then.

Changed in mixxx:
milestone: 1.9.2 → none
status: Confirmed → New
RJ Skerry-Ryan (rryan) on 2011-09-30
Changed in mixxx:
status: New → Confirmed
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2011-11-07
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers