Tag for comments is ignored for MP3, FLAC, Ogg

Bug #628779 reported by jus on 2010-09-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
RJ Skerry-Ryan
Nominated for 1.8 by azmo

Bug Description

If you use 3rd party applications (iTunes, Rapid Evolution, Mixed in Key...) and write comments to the proper id3 field in you mp3, the tag is ignored and the comments column stays blank in Mixxx.

Mixxx 1.8beta2
Issue reported on all supported platforms.

Forum discussion here: http://mixxx.org/forums/viewtopic.php?f=1&t=1624

Related branches

Mixxx doesn't read ID3 "Comments" information.

Changed in mixxx:
assignee: nobody → Irwin Céspedes B (cespedesbirwin)
Changed in mixxx:
assignee: Irwin Céspedes B (cespedesbirwin) → nobody
RAFFI TEA (raffitea) on 2010-09-05
Changed in mixxx:
assignee: nobody → RAFFI TEA (raffitea)
RJ Skerry-Ryan (rryan) wrote :

It turns out that Mixxx does not read the comment field for FLAC, MP3, or Ogg Vorbis, though it does for the M4A plugin. The change to do this was fairly simple so I added it to the 1.8 branch. I've confirmed with an Ogg, a FLAC, and an MP3.

However, an outstanding problem in Mixxx is that if file metadata ever changes, Mixxx will not notice, as it only reads it at import time.

Changed in mixxx:
importance: Undecided → Low
status: New → Fix Committed
assignee: RAFFI TEA (raffitea) → RJ Ryan (rryan)
milestone: none → 1.8.0
RJ Skerry-Ryan (rryan) on 2010-09-07
summary: - ID3 tag for comments is ignored
+ Tag for comments is ignored for MP3, FLAC, Ogg
RAFFI TEA (raffitea) wrote :

There might be a way detect changes in audio tags: My idea is to modify the computation of the library hash. As far as I know, it only considers the file names but not the file sizes for computation. If the tag changes, the file size or modified date alters which result in a new library hash. And this means we have to rescan the folder.

Albert Santoni (gamegod) wrote :

Using either the filesize or date modified would work, with the latter probably being more reliable. Presumably the files are all already being stat'ed by QDirList or whatever I used in the library scanner, so I don't think there'd be any noticeable performance hit in changing the hashing to do that. The only reasons I did it based on filenames was for simplicity.

RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers