Add playlist to Auto-DJ queue

Bug #617318 reported by olyn on 2010-08-13
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Matthew Mikolay
1.10
Wishlist
Matthew Mikolay
1.7
Wishlist
Unassigned
1.8
Wishlist
Unassigned
1.9
Wishlist
Unassigned

Bug Description

We should support adding a playlist to the Auto-DJ queue. This could happen via right-click on the playlist or something similar.

RJ Skerry-Ryan (rryan) wrote :

Hi Olyn,

Wow thanks for the report. I'm sorry that Mixxx is breaking in so many ways for you. We are all volunteers who are trying very hard to make good software, but sometimes bugs do happen.

Let's see if we can tease apart all the problems you were having into discrete bugs. First of all, which version of 1.8.0 are you using? beta1 or beta2?

1) Drag and Drop Brokenness

 If it's beta1, basically I know what's wrong -- drag and drop is mostly broken in beta1. That problem should be fixed in beta2. (Albert correct me if I'm wrong) but it may be broken on Windows 7 specifically. Not many of our developers use Windows.

2) 1.7.2 fails to place song title or filename on your songs.

What file format are they? mp3? ogg? I assume they all have their metadata written to the files. If you wouldn't mind, could you please post one of the files that you can reproduce the problem on and we'll take a look.

3) No 'Add to Auto-DJ Queue' context menu option.

This is a good idea, we should add this maybe before we release 1.8.0 final. Albert, thoughts? A separate wishlist bug should be made for this.

4) Cannot drag a playlist into the Auto-DJ Queue

We've been asked to add this before, but I think there is some problem we had or maybe we just haven't had time to get to it. A separate wishlist bug should be made for this.

5) Cannot play a playlist.

We actually do not really support playing a playlist, as this isn't really a music player software, it's DJ software. Playlists are for helping a DJ organize music from a general pool of music (e.g. a crate in 1.8.0) into a logical ordered list of songs to play during a performance. He or she can then load songs from the playlist and mix them together.

6) Record Mix feature does not work

Which format do you select for recording? In 1.8, you can check by going to Preferences > Recording. Make sure that 'WAV' is selected. Albert/Sean perhaps libsndfile is broken in 1.8 on windows?

Best regards,
RJ

Albert Santoni (gamegod) wrote :

Just to follow up with RJ's questions:

I can confirm that drag-and-drop was broken on Windows in all sorts of ways in Beta _2_. That makes 1.8.0 Beta 2 pretty crippled on Windows, but I made the decision to continue development towards the 1.8.0 final since we were proceeding at a breakneck pace last month.

'Add to Auto-DJ Queue' - Yes, we can consider doing this for 1.8.0 final. I don't think it'll be hard to implement, cross your fingers.

'Record Mix feature does not work' - We've received a number of bug reports about this, but the behaviour seems completely inconsistent. For some users, recording works fine, and I have been unable to trigger the bug where recording doesn't work. This should be filed as a separate bug though too. There may very well be a race condition in the triggering of recording (the logic is a bit complicated, not sure if it's necessary though).

Thank you for sharing this feedback with us. We'll do our best to try to address the problems that we can for our future releases.

Albert

Download full text (3.7 KiB)

All I can say, inconsistent, as the moment after submitting the report,
another reboot and tinkering I got it to work somewhat. Deleting the
non-function wav file, cleared the wav recording somewhat.

If you don't add to the ADJQ from clicking in the library then how do you do
it, after playing some songs a small list did show in the ADQJ

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Albert Santoni
Sent: Saturday, August 14, 2010 4:10 AM
To: <email address hidden>
Subject: [Bug 617318] Re: Failure on so many levels

Just to follow up with RJ's questions:

I can confirm that drag-and-drop was broken on Windows in all sorts of
ways in Beta _2_. That makes 1.8.0 Beta 2 pretty crippled on Windows,
but I made the decision to continue development towards the 1.8.0 final
since we were proceeding at a breakneck pace last month.

'Add to Auto-DJ Queue' - Yes, we can consider doing this for 1.8.0
final. I don't think it'll be hard to implement, cross your fingers.

'Record Mix feature does not work' - We've received a number of bug
reports about this, but the behaviour seems completely inconsistent. For
some users, recording works fine, and I have been unable to trigger the
bug where recording doesn't work. This should be filed as a separate bug
though too. There may very well be a race condition in the triggering of
recording (the logic is a bit complicated, not sure if it's necessary
though).

Thank you for sharing this feedback with us. We'll do our best to try to
address the problems that we can for our future releases.

Albert

--
Failure on so many levels
https://bugs.launchpad.net/bugs/617318
You received this bug notification because you are a direct subscriber
of the bug.

Status in Mixxx: New

Bug description:
OS Name Microsoft Windows 7 Ultimate
Version 6.1.7600 Build 7600
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name OLYN-PC
System Manufacturer Hewlett-Packard
System Model Compaq Presario CQ40 Notebook PC
System Type X86-based PC
Processor AMD Athlon(tm) X2 Dual-Core QL-62, 2000 Mhz, 2 Core(s), 2
Logical Processor(s)
BIOS Version/Date Hewlett-Packard F.54, 12/7/2009
SMBIOS Version 2.4
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "6.1.7600.16385"
User Name olyn-PC\olyn
Time Zone SE Asia Standard Time
Installed Physical Memory (RAM) 2.00 GB
Total Physical Memory 1.75 GB
Available Physical Memory 639 MB
Total Virtual Memory 3.50 GB
Available Virtual Memory 1.83 GB
Page File Space 1.75 GB
Page File C:\pagefile.sys

The package seems to install well enough over 1.7.2.

1.7.2 - failed to place either song title or file name as the title on fifty
percent on the songs on the imported music library folder.
The interface is no so helpful, as well as the contextual menu items are not
so inclusive. (when browsing the library and I highlight serveral songs I
would expect an option to add all to the cue. in 1.7.2 I got the option, in
1.8, it does not work
I can't engage the autoDJ because even though i selcet the feature, I have
been unable to add song...

Read more...

olyn (olyn) wrote :
Download full text (5.7 KiB)

You will find my half-baked responses under your questions below. I hope I
have helped in some small way.

Sincerely,

Olyn

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of RJ
Ryan
Sent: Friday, August 13, 2010 7:59 PM
To: <email address hidden>
Subject: [Bug 617318] Re: Failure on so many levels

Hi Olyn,

Wow thanks for the report. I'm sorry that Mixxx is breaking in so many
ways for you. We are all volunteers who are trying very hard to make
good software, but sometimes bugs do happen.

Let's see if we can tease apart all the problems you were having into
discrete bugs. First of all, which version of 1.8.0 are you using? beta1
or beta2?

Using beta 2

1) Drag and Drop Brokenness

 If it's beta1, basically I know what's wrong -- drag and drop is mostly
broken in beta1. That problem should be fixed in beta2. (Albert correct
me if I'm wrong) but it may be broken on Windows 7 specifically. Not
many of our developers use Windows.

Drag and drop works in the library and play list functions. Will have to
work that a little more, I have forgotten. I noticed it failure on the
autoDJ function and when trying to drag and drop anything from the library
to playlist, autoDJ. To get anything to work I pretty much had to DDrop
from the folder.

2) 1.7.2 fails to place song title or filename on your songs.

What file format are they? mp3? ogg? I assume they all have their
metadata written to the files. If you wouldn't mind, could you please
post one of the files that you can reproduce the problem on and we'll
take a look.

There are only mp3, wav, and mp4 in the folder. It definitely happens on
mp3 and wav. I have discovered those songs with no information in the file
properties values came into the library with no name.

3) No 'Add to Auto-DJ Queue' context menu option.

This is a good idea, we should add this maybe before we release 1.8.0
final. Albert, thoughts? A separate wishlist bug should be made for
this.

I don't know about you guys, but I really like being able to right a file or
multiple files and sending to where I want them.

4) Cannot drag a playlist into the Auto-DJ Queue

We've been asked to add this before, but I think there is some problem
we had or maybe we just haven't had time to get to it. A separate
wishlist bug should be made for this.

5) Cannot play a playlist.

We actually do not really support playing a playlist, as this isn't
really a music player software, it's DJ software. Playlists are for
helping a DJ organize music from a general pool of music (e.g. a crate
in 1.8.0) into a logical ordered list of songs to play during a
performance. He or she can then load songs from the playlist and mix
them together.

Well I worked the turntables in 78-80, but if I go on break I might want to
run a playlist while away, perhaps a thought! Oh, I worked from the current
best and memory....last resort was to play a few songs working hard to find
some that worked. LOL

6) Record Mix feature does not work

Which format do you select for recording? In 1.8, you can check by going
to Preferences > Recording. Make sure that 'WAV' is selected.
Albert/Sean perhaps libsndfile is...

Read more...

RJ Skerry-Ryan (rryan) on 2010-09-11
Changed in mixxx:
status: New → Triaged

Olyn: please download Mixxx 1.8.0 and let us know how that works for you.

RJ Skerry-Ryan (rryan) wrote :

Ok, since 1.7 is retired, I'm going to file a separate bug for the 'Add Playlist to Auto DJ Queue' and close this one. We fixed 1, 3, and 6 in 1.8.0 final I believe.

Changed in mixxx:
status: Triaged → Fix Released
status: Fix Released → Confirmed
importance: Undecided → Wishlist
RJ Skerry-Ryan (rryan) wrote :

Actually, scratch that I'm just going to rename it.

summary: - Failure on so many levels
+ Add playlist to Auto-DJ queue
description: updated
RJ Skerry-Ryan (rryan) on 2010-10-18
tags: added: easy weekend
Matthew Mikolay (mattmik) wrote :

The included patch adds support for adding playlists to the Auto-DJ Queue by right-clicking a playlist on the sidebar. It also adds support for renaming playlists and crates through right-clicking.

RJ Skerry-Ryan (rryan) wrote :

Thanks very much Matthew. Sorry we took so long to get to your patch until now. I just added your patch to the Mixxx trunk and it'll be part of Mixxx 1.10.0. I credited you in the credits as "Matthew Mikolay". Let me know if you'd like it differently.

RJ Ryan

Changed in mixxx:
assignee: nobody → Matthew Mikolay (mattmik)
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2011-12-25
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers