adding files with # in path to playlists

Bug #603984 reported by Florian Schrön on 2010-07-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Albert Santoni

Bug Description

my library-path is /home/user/Musik/
there is a subdirectory musik/#2/2_POP/ with some mp3-files.

if i'll add a file to a playlist (own or auto dj) through the browser, the file could not be added. adding directly into an player-slot is working perfectly.

when such a file i.e. /home/user/Musik/musik/#2/2_POP/track1.mp3 it is added into playlist with empty columns for artist, title, album, year, genre, track#, comment.
And when I look into the Location field there's the error. it shows /home/user/Musik/musik/

i think the problem is the hash-character.

version-info:
revision-id: <email address hidden>
date: 2010-06-28 13:57:19 +0200
build-date: 2010-07-10 15:09:36 +0200
revno: 2430
branch-nick: mixxx

pc-infos:
Linux laptop 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 08:03:28 UTC 2010 x86_64 GNU/Linux
Ubuntu 10.04 LTS (lucid)
Audio devices: nVidia Corporation MCP67 High Definition Audio (rev a1) & C-Media Electronics, Inc. Audio Adapter

Owen Bullock (owen-bullock) wrote :

This is fixed in trunk - it was because the QUrl::toLocalFile() discards anything after a hash. Albert has changed those calls to QUrl::toString(), (bug #601180)

tested on debian.

Albert Santoni (gamegod) wrote :

Thanks Owen, catching that was very much appreciated. :)

Changed in mixxx:
assignee: nobody → Albert Santoni (gamegod)
importance: Undecided → Low
milestone: none → 1.8.0
status: New → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers