Mixxx should recover the BPMs when they are manually set to 0.0

Bug #602019 reported by hiend on 2010-07-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Albert Santoni

Bug Description

If I manually set the BPM to 0.0 there is no way to return to the native BPM, with re-analysis the song.

RJ Skerry-Ryan (rryan) wrote :

Does the analyze view not allow you to run BPM detection on it? On track load it won't analyze even if the BPM is zero, so maybe we should check for 0 and run detection on track load.

Changed in mixxx:
status: New → Confirmed
milestone: none → 1.8.0
hiend (hippako) wrote :

It allows me to run the analyze, but the BPM is unrecoverable, also I try with rescanning and re-adding the song in library, but still no luck. I'm asking because is very easy to reset the BPM to 0.0 by mistake with double click on it.

RJ Skerry-Ryan (rryan) on 2010-07-24
Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) on 2010-07-24
Changed in mixxx:
importance: Undecided → Low
RJ Skerry-Ryan (rryan) wrote :

Hi hiend,

Good catch on this, Albert has added a fix and this will be in 1.8.0 final.

Regards,
RJ

Changed in mixxx:
assignee: RJ Ryan (rryan) → Albert Santoni (gamegod)
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers