Library Scan does not notice missing directories.

Bug #589969 reported by RJ Skerry-Ryan on 2010-06-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Albert Santoni

Bug Description

Confirmed in trunk r2419

Steps to reproduce:

1) Create brand new empty library.
2) Copy folder "Version 2.0" with some songs into music library
3) Start Mixxx, all songs in album show up
4) Close Mixxx
5) Rename "Version 2.0" to "Version 2.0.1"
6) Start Mixxx

What happens:
Dupes of every song in "Version 2.0" show up. No tracks show up in the Missing Tracks view.

What should happen:
The old tracks should at least show up in Missing Tracks, but this should be a case where we could re-attach the tracks to their metadata.

RJ Skerry-Ryan (rryan) on 2010-06-05
Changed in mixxx:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Albert Santoni (gamegod)
milestone: none → 1.8.0

Fixed... thanks for the help tonight RJ! :)

On Fri, Jun 4, 2010 at 9:58 PM, Launchpad Bug Tracker
<email address hidden> wrote:
> You have been subscribed to a public bug:
>
> Confirmed in trunk r2419
>
> Steps to reproduce:
>
> 1) Create brand new empty library.
> 2) Copy folder "Version 2.0" with some songs into music library
> 3) Start Mixxx, all songs in album show up
> 4) Close Mixxx
> 5) Rename "Version 2.0" to "Version 2.0.1"
> 6) Start Mixxx
>
> What happens:
> Dupes of every song in "Version 2.0" show up. No tracks show up in the Missing Tracks view.
>
> What should happen:
> The old tracks should at least show up in Missing Tracks, but this should be a case where we could re-attach the tracks to their metadata.
>
> ** Affects: mixxx
>     Importance: Medium
>     Assignee: Albert Santoni (gamegod)
>         Status: Confirmed
>
> --
> Library Scan does not notice missing directories.
> https://bugs.launchpad.net/bugs/589969
> You received this bug notification because you are a bug assignee.
>

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers