Simple MIDI output mappings stop working with multiple devices active

Bug #586891 reported by Sean M. Pappalardo on 2010-05-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
Unassigned
1.8
Medium
Owen Williams

Bug Description

Simple MIDI output mappings (that use MidiLedHandler) only work reliably when 1) you have only one device active and 2) You don't go into the preferences.

Apparently MIDI LED handlers only get created on startup, even though MidiDevice::applyPreset() is called when clicking OK in the preferences. (The outputMidiDevice must be NULL, but the script engine starts fine with the correct name, so something's fishy.)

Changed in mixxx:
milestone: 1.8.0 → none
summary: - Simple MIDI output mappings stop working with multiple devices active
+ Regression: Simple MIDI output mappings stop working with multiple
+ devices active
summary: - Regression: Simple MIDI output mappings stop working with multiple
- devices active
+ Simple MIDI output mappings stop working with multiple devices active
Albert Santoni (gamegod) on 2010-09-06
Changed in mixxx:
assignee: Albert Santoni (gamegod) → nobody
Albert Santoni (gamegod) wrote :

Committed in 1.8, r2521. Thanks Owen!

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers