Crash on Windows creating new library table

Bug #586755 reported by Sean M. Pappalardo on 2010-05-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
High
Albert Santoni

Bug Description

Trunk builds r2410 and later crash on Windows when creating a new library (after scanning 40 files of a 64-file directory.)

Mixxx stays up when run with an existing DB file.

(Tested only on Windows x64. Can't test with Windows x86 (32-bit) because it doesn't build. (Separate issue, E-mailed Albert about it.))

description: updated

This is probably a dupe of 586774....

On Fri, May 28, 2010 at 3:12 AM, Pegasus <email address hidden> wrote:
> Public bug reported:
>
> Trunk builds r2410 and later crash on Windows when creating a new
> library (after scanning 40 files of a 64-file directory.)
>
> Mixxx stays up when run with an existing DB file.
>
> (Tested only on Windows x64. Can't test with Windows x86 (32-bit)
> because it doesn't build. (Separate issue, E-mailed Albert about it.))
>
> ** Affects: mixxx
>     Importance: High
>     Assignee: Albert Santoni (gamegod)
>         Status: Confirmed
>
>
> ** Tags: crash library scan windows
>
> ** Description changed:
>
>  Trunk builds r2410 and later crash on Windows when creating a new
>  library (after scanning 40 files of a 64-file directory.)
>
> + Mixxx stays up when run with an existing DB file.
> +
>  (Tested only on Windows x64. Can't test with Windows x86 (32-bit)
>  because it doesn't build. (Separate issue, E-mailed Albert about it.))
>
> --
> Crash on Windows creating new library table
> https://bugs.launchpad.net/bugs/586755
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
>

Albert Santoni (gamegod) wrote :

Did it crash on an M4A file?

No, I have no M4As. It was either FLAC, WAV, or MP3.

Ok it was hopefully fixed yesterday... Can you try again?

On May 31, 2010 12:10 PM, "Pegasus" <email address hidden> wrote:

No, I have no M4As. It was either FLAC, WAV, or MP3.

--
Crash on Windows creating new library table
https://bugs.launchpad.net/bugs/586755
You received...

Yup, doesn't crash anymore as of r2415. (But bug #586729 still remains.)

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers