Library scan hang (deadlock) during upgrade from 1.7 library

Bug #584876 reported by Sean M. Pappalardo on 2010-05-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Medium
RJ Skerry-Ryan

Bug Description

Having run trunk/1.8, then running 1.7 and making a new 1.7 library file, running trunk again results in the LibraryScanner dead-locking on the first track (which happens to be FLAC) as it tries to upgrade the 1.7 library. The rest of the program is responsive. If I try to close Mixxx, it hangs on "delete library scanner." See attached backtraces, first from being idle after startup with the upgrade dialog displayed, second from hang on shutdown.

If I delete the mixxxdb.sqlite and mixxx.cfg files, the same problem occurs (after re-selecting the same path that was used for the 1.7 library.) All I can do is delete mixxxtrack.xml and have it rebuild a new 1.8 library.

RJ Skerry-Ryan (rryan) wrote :

Just fixed this in trunk as I was fixing the legacy cue-point import bug. It's because the legacy importer constructs TIO's using its alternate constructor, which did not initialize its mutex as recursive, while the main constructor did initialize it as recursive. That's why the rest of Mixxx was fine while just the legacy importer deadlocked.

Changed in mixxx:
status: Confirmed → Fix Committed
assignee: Albert Santoni (gamegod) → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers