hangup on exit

Bug #581665 reported by petermolnar on 2010-05-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Unassigned

Bug Description

When exiting mixxx, I get the following in the console:

Debug: [Main]: Destroying MixxxApp
Debug: [Main]: save config, 1
Debug: [Main]: close soundmanager 2
Debug: [Main]: soundmanager->close() done
Debug: [Main]: delete MidiDeviceManager
Debug: [Main]: Closing MIDI device "1. Midi Through Port-0"
Debug: [Main]: PortMIDI device "1. Midi Through Port-0" already closed
Debug: [Main]: delete soundmanager, 28
Debug: [Main]: delete master, 29
Debug: [Main]: in ~EngineMaster()
Debug: [Main]: delete channel1, 30
Debug: [Main]: delete channel2, 30
Debug: [Main]: delete buffer1, 31
Debug: [Main]: delete buffer2, 32
Debug: [Main]: delete view, 33
Debug: [Main]: ~WLibraryTableView
Debug: [Main]: SettingsDAO::setValue() failed "mixxx.db.model.playlist.header_state" : QVariant(QString, "AAAA/wAAAAAAAAABAAAAAQAAAAABAAAAAAAAAAAAAAAOAiAAAAACAAAADQAAAGQAAAABAAAAZAAABLAAAAAOAQEBAAAAAAAAAAAAAAAAAGT/////AAAAhAAAAAAAAAAEAAAAZAAAAAEAAAAAAAAAAAAAAAEAAAAAAAAETAAAAAsAAAAAAAAAAAAAAAEAAAAA") QSqlError(5, "Unable to fetch row", "database is locked")
Debug: [Main]: ~WLibraryTableView
Debug: [Main]: SettingsDAO::setValue() failed "mixxx.db.model.library.header_state" : QVariant(QString, "AAAA/wAAAAAAAAABAAAAAQAAAAABAAAAAAAAAAAAAAAVAbIVAAAACAAAABAAAABkAAAADwAAAGQAAAANAAAAZAAAAAwAAABkAAAACQAAAGQAAAAUAAAAZAAAABIAAABkAAAAAAAAAGQAAAUUAAAAFQEBAQAAAAAAAAAAAAAAAABk/////wAAAIQAAAAAAAAADQAAAAAAAAABAAAAAAAAAyAAAAAIAAAAAAAAAAAAAAABAAAAAAAAAMgAAAACAAAAAAAAAAAAAAABAAAAAAAAAAAAAAABAAAAAAAAAGQAAAABAAAAAAAAAAAAAAABAAAAAAAAAAAAAAABAAAAAAAAAGQAAAABAAAAAAAAAAAAAAABAAAAAAAAAGQAAAABAAAAAAAAAAAAAAABAAAAAA==") QSqlError(5, "Unable to fetch row", "database is locked")
Debug: [Main]: ~WLibraryTableView
Debug: [Main]: delete library scanner 51
Debug: [LibraryScanner 1]: Updating dirhash to mark as existing failed: QSqlError(5, "Unable to fetch row", "database is locked")

Config:
Ubuntu 10.04, 2.6.32-22-generic
libportaudio2 19+svn20071207
libportaudio0 18.1-6

Mixxx: revision 2394 (trunk @ 2010.05.17)

Compiled: scons prefix=/usr tuned=1 optimize=4 ladspa=1 install

petermolnar (petermolnar) wrote :

My apologies, my kernel is 2.6.32-22-generic, not 2.6.22.

description: updated
RJ Skerry-Ryan (rryan) wrote :

This is fixed now, thanks for reporting it, cadeyrn.

Changed in mixxx:
status: New → Fix Committed
milestone: none → 1.8.0
importance: Undecided → Medium
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers