Segfault on MIDI mapping preset apply/load

Bug #577981 reported by Sean M. Pappalardo on 2010-05-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
RJ Skerry-Ryan

Bug Description

Happens on trunk r2384. A segmentation fault occurs in a specific case when MidiScriptEngine::getScriptFunctions() tries to lock its mutex during MidiMapping::loadPreset(). (See attached backtrace.)

Steps to establish test conditions:
1) Start Mixxx with a MIDI controller attached
2) Activate it in the preferences (no need to load a mapping)
3) Close Mixxx so that state is saved.

Steps to reproduce:
1) Start Mixxx with a MIDI controller attached that had been activated on the last run.
2) Open preferences
3) Select that controller and de-activate it.
4) Click OK.
5) Re-open preferences
6) Select that controller
7) Activate it, and immediately load a mapping for it (whether it uses scripting or not)
8) Observe the crash

Related branches

tags: added: crash load midi preset segfault
description: updated
description: updated
description: updated
RJ Skerry-Ryan (rryan) wrote :

MidiMapping::m_pScriptEngine is NULL and there is no check for it on line 591 of midimapping.cpp. The backtrace clearly shows the MidiScriptEngine this pointer to be 0x0.

RJ Skerry-Ryan (rryan) on 2010-06-17
Changed in mixxx:
status: Confirmed → Fix Committed
assignee: Albert Santoni (gamegod) → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments