Esc key should work in dialogs

Bug #565793 reported by Sean M. Pappalardo on 2010-04-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Sean M. Pappalardo

Bug Description

It would be nice if the main GUI window released control of the Escape key when a dialog has focus, so a user can quickly tap Esc to mean "Cancel" or whatever the dialog has set for that key. This behavior would be consistent with typical GUI conventions. (Currently, Esc ALWAYS toggles full-screen mode no matter what dialog has focus, which is annoying.)

description: updated
Bill Good (bkgood) wrote :

F11 seems to be a common key for fullscreen, perhaps Mixxx could use that? It might create problems for users not expecting the change but given QT's default seems to be to cancel the open modal dialog on Esc, and that seems like it'd be rather handy if one couldn't easily reach ones mouse (but fumbling for the escape key is fairly easy on most keyboards), the benefits may outweigh the consequences.

Changed full-screen to F11 in trunk and Escape now works as expected, thanks for the suggestion. I had no idea how easy it was to do.

Changed in mixxx:
assignee: nobody → Pegasus (pegasus-renegadetech)
milestone: none → 1.8.0
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers