compile issues and errors (Linux)

Reported by KWhat on 2010-04-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Undecided
Unassigned

Bug Description

Error below when building from source on linux. Also version 200 of portmedia only builds the libportmidi.so shared object. As far as I can tell this is desired behavior. I know some platforms use both binaries so maybe there should be a check around line 603 of the src/SConscript to see if libportmidi was built with porttime support (objdump -T /usr/lib/libportmidi.so | grep Pt_Time ???)

g++ -o linux_build/mixxx.o -c -march=prescott -O2 -pipe -fomit-frame-pointer -pthread -pipe -Wall -W -g -DQT_GUI_LIB -D__SNDFILE__ -DQT_SHARED -DQT3_SUPPORT -DSETTINGS_PATH=\".mixxx/\" -DBPMSCHEME_FILE=\"mixxxbpmscheme.xml\" -DSETTINGS_FILE=\"mixxx.cfg\" -DTRACK_FILE=\"mixxxtrack.xml\" -DUNIX_SHARE_PATH=\"/usr/share/mixxx\" -Di686 -D__LINUX__ -D__UNIX__ -D__PORTAUDIO__ -DQT3_SUPPORT -DQT3_SUPPORT_WARNINGS -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -D_REENTRANT -DT_LINUX -D__IPOD__ -D__VINYLCONTROL__ -D__MIDISCRIPT__ -I/usr/lib/qt4/include -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtOpenGL -I/usr/include/qt4/Qt3Support -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSvg -I/usr/include/qt4/QtScript -I/usr/include/qt4/QtXmlPatterns -I/usr/include/qt4/QtWebKit -Ilinux_build -Isrc -I. -I/var/tmp/portage/media-sound/mixxx-1.8.0_beta1/work -I/usr/lib/qt4/include/Qt3Support -I/usr/lib/qt4/include/QtCore -I/usr/lib/qt4/include/QtGui -I/usr/lib/qt4/include/QtXml -I/usr/lib/qt4/include/QtSql -I/usr/lib/qt4/include/QtOpenGL -I/usr/lib/qt4/include/QtWebKit -I/usr/lib/qt4/include/Qt -Ilib/soundtouch-1.4.1 -Ilib/kissfft -Ilib/fidlib-0.9.9 -I/usr/include/gpod-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -Ilib/xwax -Ilib/scratchlib -I/usr/lib/qt4/include/QtScript src/mixxx.cpp
In file included from src/analyserqueue.h:10,
                 from src/mixxx.cpp:31:
src/analyser.h:19: warning: unused parameter 'tio'
src/analyser.h:19: warning: unused parameter 'sampleRate'
src/analyser.h:19: warning: unused parameter 'totalSamples'
src/analyser.h:21: warning: unused parameter 'tio'
src/mixxx.cpp: In destructor 'virtual MixxxApp::~MixxxApp()':
src/mixxx.cpp:402: error: 'm_pTrack' was not declared in this scope
src/mixxx.cpp: In member function 'void MixxxApp::slotiPodToggle(bool)':
src/mixxx.cpp:755: error: 'class MixxxView' has no member named 'm_pComboBox'
src/mixxx.cpp:755: error: 'TABLE_MODE_IPOD' was not declared in this scope
src/mixxx.cpp:756: error: 'class MixxxView' has no member named 'm_pComboBox'
src/mixxx.cpp:760: warning: 'QString::operator const char*() const' is deprecated (declared at /usr/include/qt4/QtCore/qstring.h:572)
src/mixxx.cpp:767: error: 'm_pTrack' was not declared in this scope
src/mixxx.cpp:792: error: no matching function for call to 'TrackInfoObject::TrackInfoObject(QString&, QString&)'
src/trackinfoobject.h:59: note: candidates are: TrackInfoObject::TrackInfoObject(const QDomNode&)
src/trackinfoobject.h:57: note: TrackInfoObject::TrackInfoObject(QString)
src/trackinfoobject.h:53: note: TrackInfoObject::TrackInfoObject(const TrackInfoObject&)
src/mixxx.cpp:812: error: 'class MixxxView' has no member named 'm_pComboBox'
src/mixxx.cpp:812: error: 'class MixxxView' has no member named 'm_pComboBox'
src/mixxx.cpp:818: error: 'class MixxxView' has no member named 'm_pComboBox'
src/mixxx.cpp:819: error: 'class MixxxView' has no member named 'm_pComboBox'
src/mixxx.cpp:819: error: 'class MixxxView' has no member named 'm_pComboBox'
src/mixxx.cpp:819: error: 'TABLE_MODE_LIBRARY' was not declared in this scope
src/mixxx.cpp:823: error: 'class MixxxView' has no member named 'm_pComboBox'
src/mixxx.cpp:823: error: 'class MixxxView' has no member named 'm_pComboBox'
src/mixxx.cpp: In member function 'virtual bool MixxxApp::eventFilter(QObject*, QEvent*)':
src/mixxx.cpp:1232: warning: unused variable 'keyEvent'
scons: *** [linux_build/mixxx.o] Error 1
scons: building terminated because of errors.

KWhat (alex.barker) wrote :

Looks like the compile error was caused by some bad flags (Probably ipod). The first part is still valid but far less critical and maybe the same reason that osx doesn't have libportime.so.

KWhat (alex.barker) wrote :

Small patch to fix the missing porttime. It is not needed anymore because its combined with portmidi.

RJ Ryan (rryan) wrote :

Yup, the problem is the ipod flag. That code has severely rotted and we aren't supporting it. We should just remove it.

Changed in mixxx:
status: New → Invalid
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers