Crash when enabling AutoDj

Bug #552006 reported by gimmeapill on 2010-03-30
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Albert Santoni

Bug Description

Debian testing x86, + Hercules Dj Console RMX controller
In trunk rev 2369 (1.8-pre beta2), clicking on enable autodj results in instant crash.
It seems to happen everytime if any files are queued (not that I personally use it much, but it seems like a serious problem).
gdb trace is attached

gimmeapill (gimmeapill) wrote :
RJ Skerry-Ryan (rryan) wrote :

Could be a dupe of Bug #533431

Changed in mixxx:
milestone: none → 1.8.0
tags: added: segfault
RJ Skerry-Ryan (rryan) wrote :

gimmeapill, can you reproduce this with lp:mixxx or lp:mixxx/1.8 ? It may have been fixed.

RJ Skerry-Ryan (rryan) on 2010-06-18
Changed in mixxx:
importance: Undecided → High
RJ Skerry-Ryan (rryan) wrote :

Albert says this is fixed, so I'm going to mark it fixed for now. gimmeapill, please let us know if it happens again.

Thanks,
RJ

Changed in mixxx:
status: New → Fix Committed
assignee: nobody → Albert Santoni (gamegod)
gimmeapill (gimmeapill) wrote :

Yes - the issue seems to be fixed. Thx guys

gimmeapill (gimmeapill) wrote :

Actually the crash only is fixed: it is possible to enable autodj, but with 1.8 rev2446, it just plays the first track, fades out and stops (the next track is not loaded).

pi r squared (aps80) wrote :

Same here. Occasionally I get two tracks to play in the sequence but I can't get any more than that.

I believe this was caused when I fixed the players-dont-stop-on-load bug. I
think AutoDJ is setting the next player to play before the reader finishes
loading hte track, and when the reader finishes loading the track, it stops
the player.

On Wed, Jun 23, 2010 at 1:33 PM, pi r squared <email address hidden>wrote:

> Same here. Occasionally I get two tracks to play in the sequence but I
> can't get any more than that.
>
> --
> Crash when enabling AutoDj
> https://bugs.launchpad.net/bugs/552006
> You received this bug notification because you are subscribed to Mixxx.
>

Albert Santoni (gamegod) wrote :

I may have just committed a fix for this to the 1.8 branch. If anyone
could please test Auto DJ again and let me know if the bug is fixed,
it would be greatly appreciated!

Thanks,
Albert

On Wed, Jun 23, 2010 at 9:48 PM, RJ Ryan <email address hidden> wrote:
> I believe this was caused when I fixed the players-dont-stop-on-load bug. I
> think AutoDJ is setting the next player to play before the reader finishes
> loading hte track, and when the reader finishes loading the track, it stops
> the player.
>
> On Wed, Jun 23, 2010 at 1:33 PM, pi r squared
> <email address hidden>wrote:
>
>> Same here. Occasionally I get two tracks to play in the sequence but I
>> can't get any more than that.
>>
>> --
>> Crash when enabling AutoDj
>> https://bugs.launchpad.net/bugs/552006
>> You received this bug notification because you are subscribed to Mixxx.
>>
>
> --
> Crash when enabling AutoDj
> https://bugs.launchpad.net/bugs/552006
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
>

gimmeapill (gimmeapill) wrote :

nope, still plays only the first track (next one is not loaded)

RJ Skerry-Ryan (rryan) wrote :

Just to verify, gimmeapill, are you using trunk or the 1.8 branch? The 1.8
branch is new and is located at lp:mixxx/1.8

On Thu, Jun 24, 2010 at 3:02 PM, gimmeapill <email address hidden> wrote:

> nope, still plays only the first track (next one is not loaded)
>
> --
> Crash when enabling AutoDj
> https://bugs.launchpad.net/bugs/552006
> You received this bug notification because you are subscribed to Mixxx.
>

gimmeapill (gimmeapill) wrote :

I reported the bug against trunk but I'm now testing on the 1.8 branch

RJ Skerry-Ryan (rryan) wrote :

AutoDJ can still crash -- if both decks are empty and you enable Auto-DJ a crash occurs.

Changed in mixxx:
status: Fix Committed → Confirmed
RJ Skerry-Ryan (rryan) wrote :

With songs in the AutoDJ queue and both decks empty this happens:

Debug: [AnalyserQueue 1]: SSMP3::open() - Setting duration to: 237
Fatal: []: ASSERT: "unscaled_samples_needed != 0" in file src/engine/enginebufferscalelinear.cpp, line 158
zsh: abort ./mixxx

pi r squared (aps80) wrote :

In response to Albert's question, I updated to the latest version of 1.8 and tested AutoDJ - worked perfectly for an hour long background music session - but you have to load and start playing a track before enabling AutoDJ, otherwise you get the ASSERT RJ Ryan refers to above.

Albert Santoni (gamegod) wrote :

Fixed in r2460....

Changed in mixxx:
status: Confirmed → Fix Committed
Albert Santoni (gamegod) wrote :

(in the 1.8 branch)

gimmeapill (gimmeapill) wrote :

Sorry for the late reply (i have just discovered the "subscribe" button)
Yes this is fixed

RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments