"Fatal: []: ASSERT: "current_sample >= chunk_start_sample" in file src/cachingreader.cpp, line 349"

Bug #546779 reported by petermolnar on 2010-03-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Critical
Albert Santoni
1.10
Critical
Unassigned
1.9
Critical
Unassigned

Bug Description

I could only reproduce the bug with the attached mp3; when the track reaches the end, Mixxx freeze, and puts the following on the shell:

Fatal: []: ASSERT: "current_sample >= chunk_start_sample" in file src/cachingreader.cpp, line 349

It is possible, that the mp3 is corrupted somehow, but I couldn't find anything.

petermolnar (petermolnar) wrote :
petermolnar (petermolnar) wrote :

I forgot to mention: Mixxx 1.8.0 beta 1

pi r squared (aps80) wrote :

This same error happens to me seemingly at random - for example, it occurred during the middle of a song, exiting Mixxx entirely. Played the same song again once Mixxx was running again and no problem.

For me it does *not* seem to occur if I don't adjust the pitch controls - if I keep everything at 0% it doesn't seem to occur. Otherwise it seems to happen unpredictably.

Albert Santoni (gamegod) wrote :

Hi guys,

Thanks for reporting this! I've just committed a fix to trunk that should fix this, and I can confirm that it fixes it for your song Caderyn. Pi, if you're able to reproduce this bug again with trunk, we'll reopen it and I can try to figure out what's going on.

This bugfix will be included in 1.8.0 Beta 2.

Thanks,
Albert

Changed in mixxx:
assignee: nobody → Albert Santoni (gamegod)
importance: Undecided → Medium
milestone: none → 1.8.0
status: New → Fix Committed
petermolnar (petermolnar) wrote :

Thanks a lot, I'm looking forward for it.

pi r squared (aps80) wrote :

Cheers, Albert. I tested it in a non-live environment by wanging 500 songs into the Auto DJ and ramping the pitchbends up to 8% and 16%. Left it overnight and ten hours later it was still playing - before the fix it would have "ASSERT"ed way before that so it looks like it's fixed to me.

Thanks again.

RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
pi r squared (aps80) wrote :

Ugh, this bug seems to have re-established itself. I updated to the latest trunk version a few days ago and the last two gigs* I've done have had Mixxx crash out after some time with this ASSERT. In both cases I've had tracks pitched up and on PITS but the ASSERTs seem to happen again at random.

I wouldn't purport to know what's caused this, but to my uneducated eye it looks like quite a lot of the chunk handling in cachingreader.cpp was rewritten in r2856 (the cachingreader-fixes merge) and that would tally for me as my last update would have been prior to that merge.

I can try to replicate the error and get hold of a core dump if that would be useful?

(* Yeah, I know, shouldn't use trunk version in a live environment! Usually it's rock solid though, and just in case I always have an alternative music source ready to play at a moment's notice)

Just kill me now. :)

 I'll look into it.

On Sat, Oct 15, 2011 at 11:07 PM, pi r squared <email address hidden>wrote:

> Ugh, this bug seems to have re-established itself. I updated to the
> latest trunk version a few days ago and the last two gigs* I've done
> have had Mixxx crash out after some time with this ASSERT. In both cases
> I've had tracks pitched up and on PITS but the ASSERTs seem to happen
> again at random.
>
> I wouldn't purport to know what's caused this, but to my uneducated eye
> it looks like quite a lot of the chunk handling in cachingreader.cpp was
> rewritten in r2856 (the cachingreader-fixes merge) and that would tally
> for me as my last update would have been prior to that merge.
>
> I can try to replicate the error and get hold of a core dump if that
> would be useful?
>
> (* Yeah, I know, shouldn't use trunk version in a live environment!
> Usually it's rock solid though, and just in case I always have an
> alternative music source ready to play at a moment's notice)
>
> --
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
> https://bugs.launchpad.net/bugs/546779
>
> Title:
> "Fatal: []: ASSERT: "current_sample >= chunk_start_sample" in file
> src/cachingreader.cpp, line 349"
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mixxx/+bug/546779/+subscriptions
>

RJ Skerry-Ryan (rryan) wrote :

Was it this specific assert? Also, yes please get a core dump or backtrace next time this happens!

Changed in mixxx:
importance: Medium → Critical
pi r squared (aps80) wrote :

Yep, definitely that specific ASSERT - I copied and pasted directly from the terminal into Google and this bug was top result. It was serendipity that I'd commented on it previously!

Frustratingly I am struggling to recreate - I bumped a tonne of tunes into AutoDJ overnight, messed about with the pitch controls, and yet when I woke up Mixxx had been happily playing to itself for over 8 hours without issue. I'll keep trying...

pi r squared (aps80) wrote :

Well, I've done a clean reinstall (application only, not userdata) and I've been completely unable to reproduce this. If no-one else can reproduce this either, it may just have been that I managed to cripple my install somehow originally and have now fixed it with a clean install.

RJ Skerry-Ryan (rryan) wrote :

That's good to hear. Let us know if something comes up. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers