can add crates but can't add anything to crate

Bug #531136 reported by Dave Steinberg on 2010-03-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Albert Santoni

Bug Description

mixxx 1.8 beta with windows 7 64 bit AMD Athlon Turion X2 64. Just as a side have to set latency to slow pc otherwise audio is very choppy.

RJ Skerry-Ryan (rryan) wrote :

Hey thanks for the bug report,

That's a known issue with the beta1 that will be fixed in beta2.

Also, as for your latency issue, what audio interface are you using? DirectSound, WMME, or ASIO?

If you aren't using ASIO, you should try installing ASIO4ALL. Windows doesn't get good latency unless ASIO4ALL is installed.

Cheers,
RJ Ryan

Changed in mixxx:
milestone: none → 1.8.0
status: New → Confirmed

Ryan,

       Thanks for getting back to me so quickly. After I posted the bug I researched it alittle more. I can add things to the playlists and crates if I am browsing the harddrive or cd. I am using DirectSound. I will look for the ASIO4ALL today. Thanks again for responding so quickly.

Dave

> Date: Wed, 3 Mar 2010 05:36:34 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 531136] Re: can add crates but can't add anything to crate
>
> Hey thanks for the bug report,
>
> That's a known issue with the beta1 that will be fixed in beta2.
>
> Also, as for your latency issue, what audio interface are you using?
> DirectSound, WMME, or ASIO?
>
> If you aren't using ASIO, you should try installing ASIO4ALL. Windows
> doesn't get good latency unless ASIO4ALL is installed.
>
> Cheers,
> RJ Ryan
>
> ** Changed in: mixxx
> Milestone: None => 1.8.0
>
> ** Changed in: mixxx
> Status: New => Confirmed
>
> --
> can add crates but can't add anything to crate
> https://bugs.launchpad.net/bugs/531136
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Mixxx: Confirmed
>
> Bug description:
> mixxx 1.8 beta with windows 7 64 bit AMD Athlon Turion X2 64. Just as a side have to set latency to slow pc otherwise audio is very choppy.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/mixxx/+bug/531136/+subscribe

_________________________________________________________________
Your E-mail and More On-the-Go. Get Windows Live Hotmail Free.
http://clk.atdmt.com/GBL/go/201469229/direct/01/

RJ Skerry-Ryan (rryan) wrote :

I believe the crate issue is fixed so marking this as fix commited. Beta2 will have this fix.

Changed in mixxx:
status: Confirmed → Fix Committed
Devon Johnson (devon-johnson) wrote :

On Windows XP, Mixxx 1.8.0 beta 2, it is possible to add songs to crates, however if you select several songs, only some get added.

For example, I selected tracks 1-14 of an album and dragged them to the crates window, only tracks 3,4,5,and 9 were copied into the crate. I also dragged track 6 individually to the crate and the list didn't update. When clicked a different window (such as playlist or auto dj) and then back to the crate, the window refreshed and showed the track updated.

Also you can't drag songs from either crates or playlist to auto dj, although it shows the "+" symbol, it doesn't add them. You have to drag and drop from an external windows browser. Actually all drag and drop inside mixxx doesn't seem to work except for dragging to the decks which loads the songs.

RJ Skerry-Ryan (rryan) wrote :

Thanks Devon,

Re-opened and we'll look into it some more.

RJ

Changed in mixxx:
status: Fix Committed → Confirmed
importance: Undecided → Medium
assignee: nobody → RJ Ryan (rryan)
Devon Johnson (devon-johnson) wrote :

Thanks RJ,

If you need some more details or need a tester, feel free to contact me! I've always found windows' copy function a little funky even in native windows.

Thanks,
Devon
w:765.868.5009
m:317.501.8574

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of RJ Ryan
Sent: Thursday, July 15, 2010 12:53 PM
To: Devon Johnson
Subject: [Bug 531136] Re: can add crates but can't add anything to crate

Thanks Devon,

Re-opened and we'll look into it some more.

RJ

** Changed in: mixxx
       Status: Fix Committed => Confirmed

** Changed in: mixxx
   Importance: Undecided => Medium

** Changed in: mixxx
     Assignee: (unassigned) => RJ Ryan (rryan)

--
can add crates but can't add anything to crate
https://bugs.launchpad.net/bugs/531136
You received this bug notification because you are a direct subscriber
of the bug.

Status in Mixxx: Confirmed

Bug description:
mixxx 1.8 beta with windows 7 64 bit AMD Athlon Turion X2 64. Just as a side have to set latency to slow pc otherwise audio is very choppy.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/mixxx/+bug/531136/+subscribe

Ian Proctor (ianproctor) wrote :

Version Windows 32 bit

When I tried to add a track from the browse window into a crate by dragging and dropping an entry appeared in the crate window but showed no artist, title etc and 0 duration. If I then trying to load this 'track' Mixx tried to load a track with no name from the default AppData/Local/Mixxx directory

Ian Proctor (ianproctor) wrote :

On a side issue when you get the crate working it would be usefull if the right click menu on the library and browse windows could include an Add to Crate option

Albert Santoni (gamegod) wrote :

This bug was really that drag and drop was broken in all sorts of ways on Windows. I've fixed this bug since beta2, so the fix will be in our next release. (We didn't do very much testing on Windows before we released beta2, but I've been doing almost all my development on Windows since then, so we've got a bit better coverage now.)

Thanks for reporting it guys,
Albert

Changed in mixxx:
status: Confirmed → Fix Committed
assignee: RJ Ryan (rryan) → Albert Santoni (gamegod)
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers