pressing Enter in Browse -> endless loop

Bug #528149 reported by fenugrec on 2010-02-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
High
Unassigned

Bug Description

Using Mixxx 1.8 beta or trunk (~ #2340 up to most recent):
While in the browse function of the library/playlist area of the main
window, selecting a folder then pressing Enter (i.e. to navigate up or
down through directories) causes Mixxx to go in an endless loop and flood
the output with this message:
>>>>
Debug: [Main]: activate() "/home/mus/misc/.."
>>>>

Once the loop is in progress, the UI is still relatively responsive
(it's possible to exit cleanly at this stage), but single-clicking
on any element (track / folder) in the Browse window will act as a
double-click. Single-clicking on a track freezes mixxx :
>>>>
Debug: [Main]: activate() "/home/tempmus/tone1.wav"
Debug: [Main]: TrackDAO::getTrack QThread(0x24d2230, name = "Main") "qt_sql_default_connection"
Debug: [Main]: TrackInfoObject: emitting bpmUpdated signal!
Debug: [Main]: setCuePoints 0
Debug: [Main]: activate() "/home/tempmus/tone1.wav"
Debug: [Main]: TrackDAO::getTrack QThread(0x24d2230, name = "Main") "qt_sql_default_connection"
Debug: [Main]: TrackInfoObject: emitting bpmUpdated signal!
Debug: [Main]: setCuePoints 0
Debug: [Main]: TrackDAO::updateTrackInDatabase QThread(0x24d2230, name = "Main") "qt_sql_default_connection"
Debug: [Main]: Updating track "tone1" in database...
>>>>

This is 100% repeatable with the public 1.8 beta as well as trunk code. The
bug also "works" on Win as well as Linux.

RJ Skerry-Ryan (rryan) on 2010-02-26
Changed in mixxx:
milestone: none → 1.8.0
status: New → Confirmed
importance: Undecided → High
RJ Skerry-Ryan (rryan) wrote :

I can't reproduce this anymore in lp:mixxx/1.8. Marking fix committed, not sure by whom.

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers