Loud chirps while dragging the waveform with mouse

Reported by RAFFI TEA on 2010-02-24
50
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
Unassigned
1.8
Low
Albert Santoni

Bug Description

If you *play* two tracks on Deck A and B simultaneously , while dragging one of the waveforms with the mouse, the corresponding player is likely to freeze for a second while producing a strange and awful sound. More precisely, I tried to extremely slow down or stop the the waveform, i.e., like on real turntables when you stop the rotation of the vinyl by using your hands.

This has been tested in Windows 7 X86, Dual Core 2 , 2.66 Ghz, 4 GB RAM, NI Audio 4 DJ with ASIO at 5ms latency.
This has also been tested on Windows 7 X86, Dual Core 2 , 1.67 Ghz, 4 GB RAM, NI Audio 4 DJ with ASIO at 5ms latency.

Please note that these problems do not always occur. On slower systems, however, it seems to be more likely. If you play 4 to 5 songs I'm sure you can reproduce the problem once. Maybe this bug also happens when using time-coded vinyls or jog-wheels.

RAFFI TEA (raffitea) wrote :

This bug is related to 1.8

Assuming you're building from source, what revision of trunk are you on? (use bzr revno to find out)

Changed in mixxx:
milestone: none → 1.8.0
RAFFI TEA (raffitea) wrote :

I used r2349 and Visual C++ 8.0 Express.

To get Mixxx compiled I use the *.libs and .*dlls of r2261. These libraries were were compiled with VS C++ 2008. I cannot use your current libraries since they are compiled with VC C++ 2005 which VS 2008 complains about. This might be a reason, but I don't think so.

Korin (4chons) wrote :

I'm using build 2352 on Ubuntu 9.10 and experience something similar. Every so often, dragging a waveform during playback of another track causes a sudden spike in latency, (possibly an xrun in JACK?).
The only difference I'm having is that there is no "awful sound", just a short pause in sound.

SPEET (speet) wrote :

We have the same bug with the last kernel 2.6.31-20-generic

Does this still happen with current trunk and/or the 1.8.0~beta1?

Korin (4chons) wrote :

Seems to still occasionally do so. Not quite as much, but I have changed to the new Ubuntu, so I'm not sure about how it compares.

RJ Ryan (rryan) on 2010-06-18
Changed in mixxx:
importance: Undecided → Medium
RJ Ryan (rryan) on 2010-06-18
Changed in mixxx:
status: New → Triaged
importance: Medium → High
RJ Ryan (rryan) on 2010-06-18
summary: - Playback issues while dragging the waveform with mouse
+ Loud chirps while dragging the waveform with mouse

I can't reproduce this on r2452 of the 1.8 branch. Please test again, if you would.

Changed in mixxx:
milestone: 1.8.0 → none

(That's just after beta2 for those who aren't building from scratch.)

Albert Santoni (gamegod) wrote :

Korin, can you please test again with Beta 2? We just released it:
http://www.mixxx.org/download.php

I'm marking this as low priority until we either know it's still a problem or know that it's fixed.

Changed in mixxx:
importance: High → Low
status: Triaged → Incomplete
Korin (4chons) wrote :

I'm still getting a handful of pauses when dragging the waveform, but (as before) no chirps.
See whether anyone else is reporting this.. if all else fails, I'll completely remove any trace of Mixxx from my system and reinstall it.

Albert Santoni (gamegod) wrote :

Thanks for the quick response Korin!

Are you using pitch-independent time stretch? If so, then I think this bug is a duplicate of bug #556414:

"The exact problem is that when you grab the waveform and scratch from standstill (rate=0), then all you hear is stuttering when using pitch-independent timestretch. If you grab the waveform and scratch while playing (rate != 0), then it sounds correct."

Does that sound like your problem?

Thanks again,
Albert

RAFFI TEA (raffitea) wrote :

I had this problem some time ago. Since I do not have DJ equipment in my student accommodation I cannot test it right now. But this weekend is probably a good chance to get it tested.

Korin (4chons) wrote :

I am using pitch-independent stretching. There is stuttering regardless of the position. :(
I'm also getting shittons of "Returning override for track ###" in the terminal, if that helps?

Albert Santoni (gamegod) wrote :

Should be fixed in the 1.8 branch, r2477.

Changed in mixxx:
status: Incomplete → Fix Committed
Chris (mmm-zippymail) wrote :

i have this problem with mixxx 1.8 beta 2 when using the fast forward button that i mapped to the track button of my herkules mk2

also the problem seems to be only on one channel...

i could erase the problem by switching to time indipendet time stretch and back....

Korin (4chons) wrote :

Right, have just downloaded the beta 1.8.0~beta2 source from mixxx.org again, because the crashes in 1.7 were getting too much.

This is still happening, any time I try to drag a waveform. Also, mixxx eventually gave up the ghost with this error message when I tried dragging the waveform:

Debug: [Main]: Returning override for track 5540
Debug: [Main]: Returning override for track 5540
Debug: [Main]: Returning override for track 5540
Debug: [Main]: Returning override for track 5540
Fatal: []: ASSERT: "start_sample >= 0" in file src/engine/readaheadmanager.cpp, line 60
WARNING: Child process terminated by signal 6

Advice, guys? :/

Hi Korin,

We've fixed that waveform dragging crash since beta2, so if you build
from our 1.8 branch in BZR, that should be fixed. We've also fixed
stuttering problems with pitch-independent time stretch, so I'd
definitely recommend building from BZR and testing again. You can get
our latest source for 1.8 by running:

    bzr checkout lp:mixxx/1.8

Thanks,
Albert

On Sun, Sep 12, 2010 at 9:33 AM, Korin <email address hidden> wrote:
> Right, have just downloaded the beta 1.8.0~beta2 source from mixxx.org
> again, because the crashes in 1.7 were getting too much.
>
> This is still happening, any time I try to drag a waveform. Also, mixxx
> eventually gave up the ghost with this error message when I tried
> dragging the waveform:
>
>
> Debug: [Main]: Returning override for track 5540
> Debug: [Main]: Returning override for track 5540
> Debug: [Main]: Returning override for track 5540
> Debug: [Main]: Returning override for track 5540
> Fatal: []: ASSERT: "start_sample >= 0" in file src/engine/readaheadmanager.cpp, line 60
> WARNING: Child process terminated by signal 6
>
>
> Advice, guys? :/
>
> --
> Loud chirps while dragging the waveform with mouse
> https://bugs.launchpad.net/bugs/526889
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
>

Korin (4chons) wrote :

I don't wanna jinx it, but it seems to all be working quite nicely... I'll stress-test it as much as I can tonight and see if any bugs rear their ugly heads, but this seems to work out well! :)
Cheers!
Korin

RJ Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers