Loading a new track onto a playing deck doesn't stop the deck

Bug #525922 reported by Sean M. Pappalardo on 2010-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
RJ Skerry-Ryan

Bug Description

Happens in trunk r2341.

Steps to reproduce:
1) Load track into deck 1
2) Play deck 1
3) Drag & drop or use a MIDI controller to load another track into deck 1

Expected behavior: Track loads and deck stops at cue point (if present)
Observed behavior: Track loads and deck plays from cue point

My decks are in STOP mode and this still happens. Basically, it looks like the Play CO isn't being reset to 0 on track load.

Is this by design?

Related branches

RJ Skerry-Ryan (rryan) wrote :

We should probably stop on drag-n-drop. There's an alternate possibility that we shouldn't even allow drag-n-drop to a playing deck.

RJ Skerry-Ryan (rryan) on 2010-06-17
Changed in mixxx:
status: New → Fix Committed
assignee: nobody → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers