Tool tips in the library table when the column is not wide enough to display the whole field

Bug #525903 reported by Sean M. Pappalardo on 2010-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Wishlist
Unassigned
1.8
Wishlist
Sean M. Pappalardo

Bug Description

It would be nice if a tool tip could pop up (after hovering for a second) showing the full field in the library table when the column is too narrow to show the whole thing.

description: updated
RJ Skerry-Ryan (rryan) on 2010-02-26
Changed in mixxx:
milestone: none → 1.8.0
RJ Skerry-Ryan (rryan) wrote :

Unless someone whips this up (it's easy) it's not going in 1.8.0. In order to do this, all that is required is to respond to the tooltip query (role = Qt::ToolTipRole) in every TableModel's data() method.

I have whipped this up. All library tables (except browse because I can't find where to do it) now show tool tips with the full value of the field. (Long ones like location could do with some word-wrapping though.) This is in 1.8 branch r2441.

Changed in mixxx:
milestone: 1.8.0 → none
Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers