Keyboard shortcuts cause seeking through library

Bug #523772 reported by Korin on 2010-02-18
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
RJ Skerry-Ryan

Bug Description

When using keyboard shortcuts, it changes the position of the selected track in the library.

For example, if I've got something in channel 1 and I'm seeking forward by holding down S, the highlighted song in the library will then go to the next track whose artist name starts with S, then the next, and keep going down the list of songs, which means I then have to go back to find where I was.

1) Load track into player 1 by right-clicking anywhere on its row in the library (example, right-clicking where song title is displayed)
2) Press D to start track
3) Wherever I right-clicked in the library, the highlighted row will go to the next song whose title starts with "D"

This happens regardless of the shortcut key used. The only way to prevent it is to load a track into the player, then click somewhere other than the library so it loses focus.

Smashuu (smashuu) wrote :

I'm having this problem too (1.8.0-beta1, Mac OSX 10.5), and it does it both for the library and search box. I can't get the shortcuts to work at all until I click a control button/knob/fader first; not even clicking the background takes back focus. I believe that Mixxx 1.7 used to automatically take back keyboard focus from the library when you double-clicked a track to load it, that was nicely intuitive.

Bug #217557 is possibly related?

RJ Skerry-Ryan (rryan) on 2010-02-19
Changed in mixxx:
status: New → Confirmed
milestone: none → 1.8.0
RAFFI TEA (raffitea) wrote :

This is bug has already been addressed in #501725

RJ Skerry-Ryan (rryan) wrote :

This should be fixed now in trunk.

Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
importance: Undecided → Low
status: Confirmed → Fix Committed
Korin (4chons) wrote :

It works fine for the library view, and in crates, but still seeks through in the Analyze view.

RJ Skerry-Ryan (rryan) wrote :

Hey Korin,

Nice catch! It should be fixed now.

Thanks,
RJ

summary: - Keyboard shortcuts cause seeking through library [Ubuntu 9.10]
+ Keyboard shortcuts cause seeking through library
RJ Skerry-Ryan (rryan) wrote :

Hm, it seems that if you hold down a key (ex 'd') in the library, once the key repeat kicks in it seeks through the library very rapidly.

Changed in mixxx:
status: Fix Committed → Triaged
RJ Skerry-Ryan (rryan) wrote :

I just added a fix that disables seeking through the library table for any keyboard shortcut (even auto-repeat). This is kind of wonky because keys that are not keyboard shortcuts DO seek through the library.

Changed in mixxx:
status: Triaged → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers