player 1 visual corruption

Bug #521509 reported by fenugrec on 2010-02-13
120
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Mixxx
High
Bill Good
1.7
High
Sean M. Pappalardo
1.8
High
Sean M. Pappalardo
mixxx (Debian)
Invalid
Undecided
Unassigned
mixxx (Ubuntu)
Undecided
Unassigned

Bug Description

(This bug is similar to https://bugs.launchpad.net/mixxx/+bug/197555 )
On startup, I'm getting visual corruption in Player 1's waveform
display, like this
http://yfrog.com/5imixxxplayer1g
(same as attached pic)

Going to/from full screen mode will modify the visual artifact.
The only way to fix it is to go to mixxx's preferences, change the
skin and press OK - the way the skin is refreshed seems to fix the
waveform display.
It seems once a track has been loaded to player 1, the wave display
acts properly.
Uninitialised pointer perhaps?

fenugrec (fenugrec) wrote :
RJ Skerry-Ryan (rryan) wrote :

These sort of things are usually Qt + your graphics driver's fault.

fenugrec (fenugrec) wrote :

Hm. For the record:

System
Thinkpad T61
Nvidia Quadro NVS 140M

Software
Archlinux w/ stock 2.6.31-x86_64 kernel
proprietary nvidia driver v 190.42
Qt 4.6.1
Mixxx trunk #2256

Maveloth (cashisshit) wrote :

System:
Archlinux x86_64(full updated)
Kernel 2.6.32.8 (Self Copmiled for realtime)
nvidia driver 190.53
DE: KDE 4.4
Qt: 4.6.2

Hardware:
CPU AMD Phenom x4 9950BE
RAM 4Gb DDR2 1066
Nvidia GeForce 8200(Integrated on the mainboard ASUS M3N78)

RJ Skerry-Ryan (rryan) on 2010-02-21
Changed in mixxx:
milestone: none → 1.8.0
assignee: nobody → RJ Ryan (rryan)
gimmeapill (gimmeapill) wrote :

Hi,
I could reproduce this bug on Archlinux i686 + Intel graphic chip, and I think this is more related to qt4.6.x
it happens both for mixxx 1.7.x and latest trunk.
As a workaround, I rolled back to qt 4.5.x, recompiled mixxx and everything is back to normal

For Arch x86_64, you can try this one:
http://arm.konnichi.com/extra/os/x86_64/qt-4.5.3-4-x86_64.pkg.tar.gz

My config:
Archlinux i686 (updated)
Kernel: 2.6.32.10 (standard)
X.Org X Server 1.7.5.902
Intel Corporation Mobile 945GM

ironstorm (ironstorm-gmail) wrote :

Anyone filed a bug with Nokia about this? (http://bugreports.qt.nokia.com/secure/BrowseProject.jspa)

Robelix (roland-robelix) wrote :

I can confirm that this happens with Qt 4.6 (Gentoo x86, Mobility Radeon X300)

After changin theme both waveform displays appear, but dropping songs on the waveforms does not work.

Changed in mixxx:
status: New → Triaged
petermolnar (petermolnar) wrote :

Happens here, with freshly upgraded ubuntu (Lucid).

Anna Z. (siana-sg) wrote :

Happens to me, Ubuntu Lucid, i915 graphics driver.

Committed a workaround in r2381 of trunk. I just added a rebootMixxxView(); call at the bottom of MixxxApp's constructor.
There is still increased CPU usage on Qt 4.6 though, so someone smarter than me should still take a look at this.

Changed in mixxx:
assignee: RJ Ryan (rryan) → Pegasus (pegasus-renegadetech)
importance: Undecided → Medium

This isn't Ubuntu's problem.

Changed in ubuntu:
status: New → Invalid
mathieg2 (graeme-salsaholics) wrote :

This affects me on a sony vaio with an ati graphics card. I think I'm using the open source driver, but it
might be fglrx.

Albert Santoni (gamegod) wrote :

Sean's workaround in r2381 didn't change anything for me. (ati/fglrx/ubuntu 9.10)

Albert: Does changing the skin solve your issue too? Can you also try building with Qt 4.5 and see if your problem goes away?

I think we have two distinct problems here. One which is caused by something in Qt 4.6 (vs 4.5) that is "fixed" by the way rebootMixxxView() works (which seems to be what most of the complaints are here,) and another that may be video driver-related. For the first problem, perhaps we need to review how we're setting up the GUI against Qt best practices...might we be doing something incorrectly?

I think you have merely unlinked/deleted the image which corresponds to the UV map. Solution: TAB into editmode, select (A)ll, and in the image window, create a new image with resolution you wish, like 64x64. I attach the file where i did this, with bakemap packed in. It's smaller because i used internal compression.

Donations to Siana Gearz are welcome :)

-Anna.

----------------------------------------
> Date: Sat, 8 May 2010 10:27:00 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 521509] Re: player 1 visual corruption
>
> Albert: Does changing the skin solve your issue too? Can you also try
> building with Qt 4.5 and see if your problem goes away?
>
> I think we have two distinct problems here. One which is caused by
> something in Qt 4.6 (vs 4.5) that is "fixed" by the way
> rebootMixxxView() works (which seems to be what most of the complaints
> are here,) and another that may be video driver-related. For the first
> problem, perhaps we need to review how we're setting up the GUI against
> Qt best practices...might we be doing something incorrectly?
>
> --
> player 1 visual corruption
> https://bugs.launchpad.net/bugs/521509
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Mixxx: Triaged
> Status in Ubuntu: Invalid
>
> Bug description:
> (This bug is similar to https://bugs.launchpad.net/mixxx/+bug/197555 )
> On startup, I'm getting visual corruption in Player 1's waveform
> display, like this
> http://yfrog.com/5imixxxplayer1g
> (same as attached pic)
>
> Going to/from full screen mode will modify the visual artifact.
> The only way to fix it is to go to mixxx's preferences, change the
> skin and press OK - the way the skin is refreshed seems to fix the
> waveform display.
> It seems once a track has been loaded to player 1, the wave display
> acts properly.
> Uninitialised pointer perhaps?
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/mixxx/+bug/521509/+subscribe

_________________________________________________________________
http://redirect.gimas.net/?n=M1004xWin72
Windows 7 - Alles was Du brauchst und noch viel mehr!

Anna Z. (siana-sg) wrote :

whoooops remove last message please. it went to the wrong address :)

----------------------------------------
> Date: Sat, 8 May 2010 10:27:00 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 521509] Re: player 1 visual corruption
>
> Albert: Does changing the skin solve your issue too? Can you also try
> building with Qt 4.5 and see if your problem goes away?
>
> I think we have two distinct problems here. One which is caused by
> something in Qt 4.6 (vs 4.5) that is "fixed" by the way
> rebootMixxxView() works (which seems to be what most of the complaints
> are here,) and another that may be video driver-related. For the first
> problem, perhaps we need to review how we're setting up the GUI against
> Qt best practices...might we be doing something incorrectly?
>
> --
> player 1 visual corruption
> https://bugs.launchpad.net/bugs/521509
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Mixxx: Triaged
> Status in Ubuntu: Invalid
>
> Bug description:
> (This bug is similar to https://bugs.launchpad.net/mixxx/+bug/197555 )
> On startup, I'm getting visual corruption in Player 1's waveform
> display, like this
> http://yfrog.com/5imixxxplayer1g
> (same as attached pic)
>
> Going to/from full screen mode will modify the visual artifact.
> The only way to fix it is to go to mixxx's preferences, change the
> skin and press OK - the way the skin is refreshed seems to fix the
> waveform display.
> It seems once a track has been loaded to player 1, the wave display
> acts properly.
> Uninitialised pointer perhaps?
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/mixxx/+bug/521509/+subscribe

_________________________________________________________________
http://redirect.gimas.net/?n=M1004xWin72
Windows 7 - Alles was Du brauchst und noch viel mehr!

This affects me on a fresh install of 64-bit Ubuntu 10.04 running mostly defaults. I'm using the latest Nvidia drivers. Let me know if you need any more info (I don't know what's relevant).

Albert Santoni (gamegod) wrote :

On Sat, 2010-05-08 at 10:27 +0000, Pegasus wrote:
> Albert: Does changing the skin solve your issue too? Can you also try
> building with Qt 4.5 and see if your problem goes away?
>
> I think we have two distinct problems here. One which is caused by
> something in Qt 4.6 (vs 4.5) that is "fixed" by the way
> rebootMixxxView() works (which seems to be what most of the complaints
> are here,) and another that may be video driver-related. For the first
> problem, perhaps we need to review how we're setting up the GUI against
> Qt best practices...might we be doing something incorrectly?
>

No workaround to date has worked for me, so you might be right that I
have a different issue. IIRC Mixxx hasn't worked right with compiz for
me for a while, so Qt 4.5 probably doesn't solve it for me either.

Thanks,
Albert

iltony (iltony) wrote :

Perfect! I tried Pegasus' remedy, by adding a
    rebootMixxxView();
at line 341 in
    src/mixxxview.cpp
from the sources of mixxx 1.7.2 (got with an apt-get source, apt-get build-deb and scons did the job of resolving the dependencies and compiling for me) and everything works fine.
System:
Linux antonio-laptop 2.6.31-10-rt #153-Ubuntu SMP PREEMPT RT Tue Jan 12 11:01:03 UTC 2010 x86_64 GNU/Linux
Video adapter:
NVIDIA(0): NVIDIA GPU GeForce Go 7300 (G72) at PCI:1:0:0 (GPU-0)
(proprietary NVIDIA driver installed and in use).
The problem appeared while upgrading from Karmik to Lucid and now disappeared.

iltony (iltony) wrote :

For everyone who's struggling with the problem, here is the alternative build which works form (sorry, amd64 only)

I added the workaround (along with a version check) in the 1.7 branch r2567. Version check merged to trunk in r2409. If you have Qt 4.6.0 or later, the extra rebootMixxxView() is called. If you have a version of Qt older than that, it isn't.

Robelix (roland-robelix) wrote :

I just built mixxx-1.7.2 with the workaround from r2567 on Gentoo x86.

Both waveform displays appear after startup - BUT: dropping songs on the waveforms does not work. (and I'm used to load songs this way) Exactly the same happens without the patch after changing the theme.

Albert Santoni (gamegod) wrote :

On Sat, May 29, 2010 at 2:41 PM, Robelix <email address hidden> wrote:
> I just built mixxx-1.7.2 with the workaround from r2567 on Gentoo x86.
>
> Both waveform displays appear after startup - BUT: dropping songs on the
> waveforms does not work. (and I'm used to load songs this way) Exactly
> the same happens without the patch after changing the theme.
>

We fixed a bug in trunk where drag and drop was broken after
rebootMixxxView() was called. Sounds like this exact problem...

iltony (iltony) wrote :

I confirm Robelix's segnalation: dropping songs on the waveforms does not work on lucid with patched mixxx.

Robelix (roland-robelix) wrote :

> We fixed a bug in trunk where drag and drop was broken after
> rebootMixxxView() was called. Sounds like this exact problem...

Is it this one?
http://bazaar.launchpad.net/~mixxxdevelopers/mixxx/trunk/revision/2354

Albert Santoni (gamegod) wrote :

This one: http://bazaar.launchpad.net/~mixxxdevelopers/mixxx/trunk/revision/2406
:)

On Sun, May 30, 2010 at 4:06 AM, Robelix <email address hidden> wrote:
>> We fixed a bug in trunk where drag and drop was broken after
>> rebootMixxxView() was called. Sounds like this exact problem...
>
> Is it this one?
> http://bazaar.launchpad.net/~mixxxdevelopers/mixxx/trunk/revision/2354
>
> --
> player 1 visual corruption
> https://bugs.launchpad.net/bugs/521509
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
>

Robelix (roland-robelix) wrote :

Tried to apply http://bazaar.launchpad.net/~mixxxdevelopers/mixxx/trunk/revision/2406 to 1.7.2 - this just gives an error at startup - it fails to disconnect a signal. Then mixxx works, but without drag-n-drop.

At the moment I'm trying 1.8 rev. 2421 - The waveform and d'n'd issues are solved in this rev. Still testing if there is other foo that keeps me from using this, but so far it looks good.

RAFFI TEA (raffitea) wrote :

QT 4.6.3 has been released a couple of days ago. Now, we get visual corruptions even on Windows, see attachment.

RAFFI TEA (raffitea) wrote :

I have posted a QT bug report for our visual corruption issue, see http://bugreports.qt.nokia.com/browse/QTBUG-11528
The core developers might want to add additional information just for clarity.

gimmeapill (gimmeapill) wrote :

I don't know if this is useful, but the problem doesn't seem to happen anymore with Mixxx 1.8b2 and qt 4.6.3-1 (on arch linux x86)...

jus (jus) wrote :

FYI the bug Tobias reported to QT was closed as duplicate.
The "original" QT bug is marked as solved and patch should be in the upcoming QT 4.6.4 release (or current QT trunk)

http://bugreports.qt.nokia.com/browse/QTBUG-11432

RAFFI TEA (raffitea) wrote :

Awesome, the QT guys are fast. I'll try to checkout QT 4.6.4 trunk and give it a shot.

RAFFI TEA (raffitea) wrote :

I used a customized QT 4.6.3 build which fixes visual curruptions on Windows. The patch can be found here: http://qt.gitorious.org/qt/qt/commit/38adb59a9e80a23d37ff0820ef62ebd45ab1e4ae

gimmeapill (gimmeapill) wrote :

problem is fixed for me as of trunk 1.8 r2845 (arch linux i686 - qt 4.6.3)

Korin (4chons) wrote :

Yeah, Player 1 used to not show up until I rebooted the skin, in 1.7.2, or deleted mixxx.cfg before loading up.
Trunk r2555 on Ubuntu 10.04 seems to be working nicely nicely. :)

RJ Skerry-Ryan (rryan) wrote :

Cool, I'm marking this fixed in the 1.8 series then. 1.7 doesn't have the workaround I don't think.

Changed in mixxx:
importance: Medium → High
milestone: 1.8.0 → none
status: Triaged → Fix Committed
Matthias Klumpp (ximion) on 2010-09-13
affects: ubuntu → mixxx (Ubuntu)
Changed in mixxx (Ubuntu):
status: Invalid → Confirmed
Changed in mixxx (Debian):
status: New → Confirmed
Bill Good (bkgood) on 2010-09-13
Changed in mixxx:
status: Fix Committed → Confirmed
Bill Good (bkgood) wrote :

Bug still present in 1.8-bzr r2567 with mixxx.cpp workaround disabled. Marking confirmed.

qt 4.6.3
xf86-video-intel 2.12.0
mesa 7.8.2

RJ Skerry-Ryan (rryan) on 2010-09-23
Changed in mixxx:
status: Confirmed → Triaged
Alessio Treglia (quadrispro) wrote :

No bug was filed against the package for Debian.
Setting this as Invalid.

Changed in mixxx (Debian):
status: Confirmed → Invalid
Changed in mixxx (Ubuntu):
status: Confirmed → Triaged
Alessio Treglia (quadrispro) wrote :

bug #645804 should fix this

Changed in mixxx (Ubuntu):
status: Triaged → Fix Released
Bill Good (bkgood) wrote :

Fixed in trunk r2512. For whatever reason, if you make your QFrame, call MixxxApp::setCentralWidget on it, then add your (pixmap-filled) qlabel as a background and then your two qglwidget waveforms, the first waveform gets all corrupted (at least, I think that was the final diagnosis). The solution (hack) is to call setCentralWidget after all the widgets are created, in both the initial skin loading and the reboot method for skin changing.

This should probably go upstream to Qt, it looks like it's not dependent on graphics drivers, as was my original suspicion (at least on linux). I commented out the rebootMixxxView hack with instructions to myself to remove it if this fix works for everyone. Many thanks to RJ.

Changed in mixxx:
assignee: Sean M. Pappalardo (pegasus-renegadetech) → Bill Good (bkgood)
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
Bill Good (bkgood) wrote :

FYI the original rebootMixxxView hack is still sufficient for users of pre-1.9, the setCentralWidget changes only became necessary after the merging of uglyduckling into trunk.

Changed in mixxx:
milestone: none → 1.9.0
status: Fix Released → Fix Committed
hiend (hippako) wrote :

Is it possible to add full Open GL acceleration instead of rendering in QT? I suppose every bug related to waveforms will be fixed once and forever.

RJ Skerry-Ryan (rryan) wrote :

hey hiend,

The waveforms are rendered using QtOpenGL so, assuming Qt is working correctly, the waveforms are OpenGL accelerated.

There are a bunch of waveform issues that need to be fixed though: https://bugs.launchpad.net/mixxx/+bugs?field.tag=waveform

Thanks,
RJ

RJ Skerry-Ryan (rryan) on 2011-02-20
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers