Stuttering playback when resizing other windows (Windows OS)

Bug #520404 reported by Sean M. Pappalardo on 2010-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Unassigned

Bug Description

Testing on Windows XP Pro x64, 32-bit build of trunk (and features_scriptTimers) on dual dual-core Opteron 2.0GHz system, nVidia Quadro FX 1400 GPU:

When playing music and you minimize or restore another window (like a folder view) Mixxx sometimes stutters while the window bar is animating into position. It's more likely to happen during track analysis. It doesn't matter if the Mixxx window is full-screen, normal size, or minimized.

Steps to reproduce:
1) Start Mixxx
2) Load a song & start it playing
3) Minimize/restore/maximize another window repeatedly until you hear the problem.

This is a regression since it doesn't happen with 1.7.2.

description: updated
RJ Skerry-Ryan (rryan) wrote :

This is probably because minimizing-maximizing causes the library to select(). I'm not sure why that happens, but it shouldn't because the SQL table model already has all the appropriate data for the query.

Did you try anything to fix it? This still happens in r2339, on the x64 build too.

Changed in mixxx:
status: New → Confirmed

Works fine now in trunk r2409.

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers