1.8 beta1 "Scratch" control is much faster backwards than forwards

Reported by vsr600 on 2010-02-10
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Sean M. Pappalardo

Bug Description

iMac 3.06 GHz Intel Core 2 Duo, OSX 10.6.2, built in sound card.
Set up vinyl control exactly as in 1.7.2 and rotating record backwards moves track faster (backwards) than rotating record forward. This makes it impossible to scratch. Vinyl control operates fine with 1.7.2.

RJ Ryan (rryan) wrote :

Hi vsr600 -- thanks for your bug report.

I'll take a look at this and see what changed.

Thanks,
RJ

Changed in mixxx:
milestone: none → 1.8.0
assignee: nobody → RJ Ryan (rryan)
importance: Undecided → Medium

I see this with MIDI controllers as well. Something's goofed up in the "scratch" control.

Changed in mixxx:
status: New → Confirmed
summary: - 1.8 beta1 Vinyl control back cue not same as forward cue
+ 1.8 beta1 "Scratch" control is much faster backwards than forwards

+1 here too. I tried Vinyl control the other day with the 1.8 beta on
windows. When I would throw back the vinyl to do a scratchb it sounded
like it was seeking, not like it was scratching. In other words, it
was going way too fast.

Anders Gunnarsson (d00guan) wrote :

I experience this too with midi controller. I think it was the same in previous version I used. 1.7.1.

Owen Williams (ywwg) wrote :

I've been working on fixing the vinyl control code, and I think this bug has been fixed -- at least for vinyl. I may have also fixed (or further broken) this bug for other devices in the process. Please try the tree at lp:~ywwg/mixxx/features_xwax and let me know if it is worse / better / the same.

There may have been vinyl control bugs that led to this, but the way the
engine handled the scratch, jog, and wheel controls has definitely changed.
I'm looking at fixing them so that they match the behavior in 1.7.x.

On Mon, Mar 1, 2010 at 9:46 AM, Owen Williams <email address hidden>wrote:

> I've been working on fixing the vinyl control code, and I think this bug
> has been fixed -- at least for vinyl. I may have also fixed (or further
> broken) this bug for other devices in the process. Please try the tree
> at lp:~ywwg/mixxx/features_xwax and let me know if it is worse / better
> / the same.
>
> --
> 1.8 beta1 "Scratch" control is much faster backwards than forwards
> https://bugs.launchpad.net/bugs/519892
> You received this bug notification because you are a bug assignee.
>

Albert Santoni (gamegod) wrote :

The vinyl control code in 1.8 (trunk) uses the "scratch" control
extensively, so any change in the behaviour of that control probably
screwed up vinyl control. I should have realized this earlier, my
bad....

On Mon, Mar 1, 2010 at 9:05 AM, RJ Ryan <email address hidden> wrote:
> There may have been vinyl control bugs that led to this, but the way the
> engine handled the scratch, jog, and wheel controls has definitely changed.
> I'm looking at fixing them so that they match the behavior in 1.7.x.
>
> On Mon, Mar 1, 2010 at 9:46 AM, Owen Williams <owen-
> <email address hidden>>wrote:
>
>> I've been working on fixing the vinyl control code, and I think this bug
>> has been fixed -- at least for vinyl.  I may have also fixed (or further
>> broken) this bug for other devices in the process.  Please try the tree
>> at lp:~ywwg/mixxx/features_xwax and let me know if it is worse / better
>> / the same.
>>
>> --
>> 1.8 beta1 "Scratch" control is much faster backwards than forwards
>> https://bugs.launchpad.net/bugs/519892
>> You received this bug notification because you are a bug assignee.
>>
>
> --
> 1.8 beta1 "Scratch" control is much faster backwards than forwards
> https://bugs.launchpad.net/bugs/519892
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
>

Owen Williams (ywwg) wrote :

Take a look at the changes I made to ratecontrol.cpp. I didn't have to do much to fix vinyl scratching, and as long as the scratch value is the same for other devices (centered around 1.0) it should probably work.

Phillip Whelan (pwhelan) wrote :

It looks like your changes disable scratching without vinyl control.
Besides that, it only looks like seeking is improved with vinyl
control, but not scratching.

Fix committed in fixes_scratch branch. Vinyl control needs to be adjusted to work with it though.

Changed in mixxx:
assignee: RJ Ryan (rryan) → Pegasus (pegasus-renegadetech)
status: Confirmed → In Progress
Sentenza (sentenzux) wrote :

Same problems for me using an SCS3d midi controller

Albert Santoni (gamegod) wrote :

Sean, how are we going to fix this for 1.8?

Are you planning on merging this branch into trunk and fixing vinyl control?

If that's the plan, can you explain what changes you've made to the
behaviour of the scratch control object and see if Owen can make vinyl
control work in your fixes_scratch branch?

Thanks,
Albert

On Tue, Apr 6, 2010 at 8:52 AM, Sentenza <email address hidden> wrote:
> Same problems for me using an SCS3d midi controller
>
> --
> 1.8 beta1 "Scratch" control is much faster backwards than forwards
> https://bugs.launchpad.net/bugs/519892
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
>

The preferred route is to merge fixes_scratch in time for 1.8.

I basically made the Scratch control work like it does in 1.7 with the deck paused, only now it does that regardless of the deck's Play status (allowing you to bring the deck to a stop even with play==1.)

See bug #530281 for more details. (https://bugs.launchpad.net/mixxx/+bug/530281)

So to fix vinyl control the quickest way, you basically just need to leave scratch_enable set to 1 as long as vinyl control is enabled (and 0 when it isn't.) Then you manipulate scratch as usual, though it might need some tuning. (A nice touch would be to set play to 1 if scratch>=1 or something since that's now possible.)

Owen Williams (ywwg) wrote :

In my opinion, fixing this small bug wouldn't fix vinyl control in trunk. No offense to the original code, but there are a lot of issues in that feature. Rather than spend time trying to patch up the old code, I think we should consider disabling vinyl control completely until my branch is ready to be merged in. That might provide some motivation to get it wrapped up and done.

And really, it's already close to beta quality. The only major bug right now is the waveform overview widget needs to be fixed for the new value range (-1 to 1 instead of 0 to 1).

OK, as discussed with Albert, the old 1.7 behavior has been added to fixes_scratch under the "scratch" control and works exactly as before (tested with the 1.7 SCS.3d mapping & script.) The new behavior is now under "scratch2" and "scratch2_enable" controls, which take precedence over the "scratch" control if they were both to be activated. (In the future, we can just remove the old "scratch", rename "scratch2" to "scratch" and search & replace in mappings and scripts.)

Fixes_scratch has been merged to trunk.

Changed in mixxx:
status: In Progress → Fix Committed
RJ Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers