Mixxx 1.8 beta1 hotcue saving error and crash when using Track editor

Bug #518101 reported by jus on 2010-02-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
High
RJ Skerry-Ryan

Bug Description

Step 1
Load mp3, set one ore more Hotcues to the track.

Step 2
Close and reopen Mixxx, select same track and open Trackeditor via right-click.

Actual Result
*Only one Hotcue (even when more are set) is shown with the wrong position
*When editing or adding Hotcue via Trackeditor Mixxx`crash.

Expected Result
* All Hotcues to be shown with the correct position
* All Hotcues editable without hang and crash

See screenshot & crashlog

jus (jus) wrote :
jus (jus) wrote :
RJ Skerry-Ryan (rryan) on 2010-02-06
Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
status: New → Confirmed
milestone: none → 1.8.0
importance: Undecided → High
tags: added: crash
tags: added: hotcue
RJ Skerry-Ryan (rryan) wrote :

This should be fixed now. Verified fine for me on the Deere skin -- hotcues in the overview line up with their actual position now and the track information dialog shows them properly and doesn't crash when you click apply.

Changed in mixxx:
status: Confirmed → Fix Committed
jus (jus) wrote :

Nice,the crash is gone :-) But there may some minor errors left.

Track information dialog:
*Position for (Hot)cues is shown twice the actual value. A (Hot)cue set at 0:10.00 shows up as 0:20.00.
*You can not delete or activate (Hot)Cues via the the corresponding buttons in track information dialog.
*If a (Hot)cue is deleted via GUI, the position remains in the database. Only the (Hot)cue number is set to -1.

see screenshot

RJ Skerry-Ryan (rryan) wrote :

Hey Jus,

I just fixed the doubled-position issue and the delete button. I don't think that activate will work for this release because it's ambiguous which deck the person means for it to play on. (the same track could be loaded in both decks). I'll probably remove it.

Not sure if you noticed, but in trunk no changes to tracks or cues save. I revived the features-sqlite branch to fix this problem mixxx-wide.

When you delete a hotcue via hotcue_xxx_clear, it just resets the cue's hotcue to -1. This is intentional so that if you spent time setting up your tracks hotcue's (adding labels, etc), then accidentally right-clicking a hotcue button will never actually delete it. The track info dialog shouldn't show the -1 though, it should just show it as blank.

Thanks,
RJ

RJ Skerry-Ryan (rryan) wrote :

nope, not removing hotcue_xxx_activate, possibly removing the 'Activate' button in hte track dialog :)

RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers