1.7.2 package built with LADSPA turned on

Bug #514924 reported by RJ Skerry-Ryan on 2010-01-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Sean M. Pappalardo
1.7
Low
Sean M. Pappalardo

Bug Description

If there is going to be a Mixxx 1.7.3, we need to build the package with LADSPA turned off. This causes both extra processing time in the callback thread (EngineLADSPA does work even with no plugins turned on) and the skin switching problems details in Bug #384963.

RJ Skerry-Ryan (rryan) on 2010-01-30
Changed in mixxx:
milestone: none → 1.7.3
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Albert Santoni (gamegod)

We should set ladpsa=0 to be the default in the 1.7 branch, then merge
1.7->trunk again...

On Sat, Jan 30, 2010 at 3:07 PM, Launchpad Bug Tracker
<email address hidden> wrote:
> You have been subscribed to a public bug:
>
> If there is going to be a Mixxx 1.7.3, we need to build the package with
> LADSPA turned off. This causes both extra processing time in the
> callback thread (EngineLADSPA does work even with no plugins turned on)
> and the skin switching problems details in Bug #384963.
>
> ** Affects: mixxx
>     Importance: Low
>     Assignee: Albert Santoni (gamegod)
>         Status: Confirmed
>
> --
> 1.7.2 package built with LADSPA turned on
> https://bugs.launchpad.net/bugs/514924
> You received this bug notification because you are a bug assignee.
>

Changed in mixxx:
milestone: 1.7.3 → none
status: Confirmed → Invalid

Fixed in r2560 of the 1.7 branch. (Some #ifdefs were missing to get Mixxx to build and not segfault with LADSPA disabled.)

Changed in mixxx:
assignee: Albert Santoni (gamegod) → nobody
status: Invalid → Confirmed
assignee: nobody → Pegasus (pegasus-renegadetech)
milestone: none → 1.8.0
Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers