Tracks not saved unless unloaded

Bug #512974 reported by Sean M. Pappalardo on 2010-01-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
RJ Skerry-Ryan

Bug Description

On trunk r2277, a new track's analysis results (BPM and overview waveform) are not saved unless another track is loaded into that deck.

Steps to repeat:
1) Start Mixxx, load a never-been-analyzed track
2) Wait for analysis to finish (overview appears)
3) Close Mixxx
4) Open Mixxx again, load the same track, note that it has to re-analyze
5) Load another track into the same deck.
6) Close Mixxx
7) Open Mixxx, load the original track and note that the overview comes up immediately.

Changed in mixxx:
importance: Undecided → High
milestone: none → 1.8.0

We only save track metadata back to the DB when a track is unloaded
from a player, so that's why this bug occurs.

On Tue, Jan 26, 2010 at 1:27 PM, Pegasus <email address hidden> wrote:
> Public bug reported:
>
> On trunk r2277, when a new track's analysis results (BPM and overview
> waveform) are not saved unless another track is loaded into that deck.
>
> Steps to repeat:
> 1) Start Mixxx, load a never-been-analyzed track
> 2) Wait for analysis to finish (overview appears)
> 3) Close Mixxx
> 4) Open Mixxx again, load the same track, note that it has to re-analyze
> 5) Load another track into the same deck.
> 6) Close Mixxx
> 7) Open Mixxx, load the original track and note that the overview comes up immediately.
>
> ** Affects: mixxx
>     Importance: High
>         Status: New
>
> ** Changed in: mixxx
>   Importance: Undecided => High
>
> ** Changed in: mixxx
>    Milestone: None => 1.8.0
>
> --
> Overview waveform (analysis) not saved to DB right away
> https://bugs.launchpad.net/bugs/512974
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
>

description: updated

Not high priority...

Changed in mixxx:
importance: High → Low
status: New → Confirmed
RJ Skerry-Ryan (rryan) wrote :

This is provoked by the fact that we don't save data on shutdown, only on track unload. This isn't a problem in the sqlite branch anymore given that I save on shutdown as well. Saving immediately to the DB isn't really an option because of the xrun issue.

Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) wrote :

I'm hijacking this bug -- the waveform would be saved if the track was saved on shutdown -- but in trunk tracks are only saved when they are unloaded. I'm working on fixing this in features_sqlite.

summary: - Overview waveform (analysis) not saved to DB right away
+ Tracks not saved unless unloaded
RJ Skerry-Ryan (rryan) wrote :

The fix is merged to trunk now, closing.

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers