Crash when setting latency to 1ms

Bug #505118 reported by jus on 2010-01-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Medium
RJ Skerry-Ryan

Bug Description

Tested with MacOS 10.5.8 & 10.6.2 / Mixxx r2255

If latency is changed to 1ms Mixxx will crash on two circumstances.

1. Open Mixxx, load a song and hit play, goto preferences and change latency to 1ms. Crash.
2. Open Mixxx, goto preferences and change latency to 1 ms. Load a song and hit play. Crash.

http://dl.dropbox.com/u/3077984/Crash_Mixxx_r2255_os10.6.2_latency_1ms.mov

Does not affect Mixxx 1.7.2

jus (jus) wrote :
Albert Santoni (gamegod) on 2010-01-11
Changed in mixxx:
importance: Undecided → Medium
status: New → Triaged
milestone: none → 1.8.0
RJ Skerry-Ryan (rryan) wrote :

Hey Jus,

Could you post your Mixxx log output when this happens? (Are you able to reproduce it regularly?)

I think there are various parts of the mixing engine which make assumptions about the buffer size being a certain length. For example, the linear interpolating scaler assumes the buffer is larger than an rate-interpolation length, which can lead to bad array accesses. We should take a look and clean these up.

This is probably related to or the same thing as what I saw in bug #513130.

jus (jus) wrote :

Yes, it crashed always with Fatal: []: ASSERT: "unscaled_samples_needed >= 0" in file src/engine/enginebufferscalelinear.cpp, line 126

Latest version tested is r2270.

jus (jus) wrote :

Just tested with r2284. Same result, problem persist.

Fatal: []: ASSERT: "unscaled_samples_needed >= 0" in file src/engine/enginebufferscalelinear.cpp, line 134

RJ Skerry-Ryan (rryan) wrote :

Yes -- it is the same problem as Bug #513130 except that one is actually two bugs, so I'm just going to rename that bug.

Changed in mixxx:
status: Triaged → Confirmed
assignee: nobody → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) wrote :

This bug is because the buffer size at 1ms is smaller than RATE_LERP_SAMPLES in EngineBufferScaleLinear. It's an easy fix.

RJ Skerry-Ryan (rryan) wrote :

Just committed the fix.

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers