Cannot sort column features_sqlite r2355

Bug #502773 reported by rfcmedia on 2010-01-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
High
RJ Skerry-Ryan

Bug Description

In Library, Auto DJ (both outside and inside Playlists), user created playlists, and user created crates, sorting columns by clicking the header does not work. Sorting by columns works for Browse and Analyze views.

RJ Skerry-Ryan (rryan) wrote :

Yea -- at some point we regressed on sorting. I'm not sure how quite yet but it's on my list of things to do so it's good to get a bug open about it.

Changed in mixxx:
milestone: none → 1.8.0
assignee: nobody → RJ Ryan (rryan)
importance: Undecided → High
status: New → Confirmed
RJ Skerry-Ryan (rryan) wrote :

Fixed -- this was QHeaderView saving related.

Changed in mixxx:
status: Confirmed → Fix Committed
jus (jus) wrote :

This bug re-surfaced for me with Ubuntu 10.04 LTS (in a virtual machine if that matters) and latest lp:mixxx/1.8

Sorting by columns works for only for Browse view.

RJ Skerry-Ryan (rryan) wrote :

Hmm. I can't reproduce. My libraries sort fine and I'm on 10.04 LTS x64. Odd.. we didn't change anything related to this either.

RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
Luis Perez (perezil) wrote :

Sorting and shuffling at big a big "want" especially, when using Auto DJ. Please proceed with enhancement.

RJ Skerry-Ryan (rryan) wrote :

Hi Luis,

This bug is already fixed. If you can't sort the auto-dj playlist in Mixxx 1.9.0, please file a separate bug.

Thanks!
RJ Ryan

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers