features_sqlite r2349 "no such table: Library" for fresh ~/.mixxx

Bug #502189 reported by rfcmedia on 2010-01-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
High
RJ Skerry-Ryan

Bug Description

This seems to result from some sql stmts failing when starting after deleting ~/.mixxx directory
Probably some bug with the table creation stuff?
Wish I could help debug this stuff. Unfortunately I don't know the code at all...

[...]
Debug: [Main]: Setting up LADSPA EnableEffect "0"
Debug: [Main]: Key string: "EnableEffect0"
Debug: [Main]: Setting up LADSPA EnableEffect "1"
Debug: [Main]: Key string: "EnableEffect1"
Debug: [Main]: Setting up LADSPA EnableEffect "2"
Debug: [Main]: Key string: "EnableEffect2"
[New Thread 0xb111bb70 (LWP 3426)]
Debug: [Main]: WLibrary::switchToView "WTrackTableView"
Debug: [Main]: MixxxLibraryFeature::activate()
Debug: [Main]: Library::slotShowTrackModel QSortFilterProxyModel(0x8597c80)
Debug: [Main]: WTrackTableView::loadTrackModel() QSortFilterProxyModel(0x8597c80)
[New Thread 0xb085ab70 (LWP 3427)]
Debug: [Main]: WLibrary::switchToView "WTrackTableView"
Debug: [Main]: LibraryTableModel::currentSearch(): ""
[New Thread 0xb0059b70 (LWP 3428)]
Debug: [Main]: PlaylistDAO::getPlaylistIdFromName QThread(0x83e81e8, name = "Main") "qt_sql_default_connection"
Debug: [Main]: getPlaylistIdFromName: QSqlError(-1, "Parameter count mismatch", "")
Debug: [Main]: PlaylistDAO::createPlaylist QThread(0x83e81e8, name = "Main") "qt_sql_default_connection"
Debug: [Main]: inserting playlist "Auto DJ" at position 0
Debug: [Main]: "INSERT INTO Playlists (name, position) VALUES (:name, :position)"
Debug: [Main]: QSqlError(-1, "Parameter count mismatch", "")
Debug: [Main]: PlaylistDAO::getPlaylistIdFromName QThread(0x83e81e8, name = "Main") "qt_sql_default_connection"
Debug: [Main]: getPlaylistIdFromName: QSqlError(-1, "Parameter count mismatch", "")
Debug: [Main]: PlaylistTableModel::setPlaylist -1
Debug: [Main]: "CREATE TEMPORARY VIEW 'playlist_-1' AS SELECT PlaylistTracks.position,library.id,library.artist,library.title,library.album,library.year,library.duration,library.genre,library.tracknumber,library.bpm,library.comment,library.mixxx_deleted FROM library INNER JOIN PlaylistTracks ON library.id=PlaylistTracks.track_id WHERE PlaylistTracks.playlist_id=-1 ORDER BY PlaylistTracks.position " QSqlError(-1, "Unable to fetch row", "No query")
Debug: [Main]: WTrackTableView::loadTrackModel() PlaylistTableModel(0x9123b38)
[New Thread 0xaf7ccb70 (LWP 3429)]
Debug: [Main]: slotSearch() "" QThread(0x83e81e8, name = "Main")
Debug: [Main]: WTrackTableView::loadTrackModel() PrepareLibraryTableModel(0x914ed88)
Debug: [Main]: Constructed LibraryScanner!!!
[New Thread 0xaefcbb70 (LWP 3430)]
[New Thread 0xadddbb70 (LWP 3431)]
Debug: [LibraryScanner 1]: LibraryHashDAO::initialize LibraryScanner(0x913f910, name = "LibraryScanner 1") "LIBRARY_SCANNER"
Debug: [LibraryScanner 1]: CueDAO::initialize LibraryScanner(0x913f910, name = "LibraryScanner 1") "LIBRARY_SCANNER"
Debug: [LibraryScanner 1]: TrackDAO::initialize LibraryScanner(0x913f910, name = "LibraryScanner 1") "LIBRARY_SCANNER"
Debug: [LibraryScanner 1]: SELECT hash failed: QSqlError(-1, "Parameter count mismatch", "")
Debug: [LibraryScanner 1]: LibraryHashDAO::saveDirectoryHash LibraryScanner(0x913f910, name = "LibraryScanner 1") "LIBRARY_SCANNER"
Debug: [LibraryScanner 1]: Creating new dirhash failed: QSqlError(-1, "Parameter count mismatch", "")
Debug: [LibraryScanner 1]: created new hash 129085779
Debug: [LibraryScanner 1]: TrackCollection::importDirectory( "/home/aki/Music" )
Debug: [LibraryScanner 1]: TrackDAO::invalidateTrackLocations LibraryScanner(0x913f910, name = "LibraryScanner 1") "LIBRARY_SCANNER"
Debug: [LibraryScanner 1]: Couldn't mark tracks in directory "/home/aki/Music" as needing verification. QSqlError(-1, "Parameter count mismatch", "")
Debug: [LibraryScanner 1]: Couldn't mark track "/home/aki/Music/Disney - Aladdin - A Whole New World.mp3" as verified. QSqlError(-1, "Parameter count mismatch", "")
[New Thread 0xad5dab70 (LWP 3432)]
[New Thread 0xacdd9b70 (LWP 3433)]
[New Thread 0xac5d8b70 (LWP 3434)]
Debug: [MidiObject 1]: MidiMapping: Loading MIDI XML from "/home/aki/.mixxx/MixxxMIDIBindings.xml"
Debug: [MidiObject 1]: Could not open xml file: "/home/aki/.mixxx/MixxxMIDIBindings.xml"
Debug: [Main]: selectedAPI is: "ALSA"
Debug: [Main]: Setting qConfigPath from location in resourcePath commandline arg: "/opt/mixxx-1.8/share/mixxx"
Debug: [Main]: Setting qConfigPath from location in resourcePath commandline arg: "/opt/mixxx-1.8/share/mixxx"
Debug: [Main]: loadSettings: 1 0 ""
Debug: [Main]: slotApply crossfader: 1 ""
Debug: [Main]: BPM Scheme File ConfigKey not set or file missing... setting to "/home/aki/.mixxx/mixxxbpmscheme.xml"
Debug: [Main]: BpmSchemes::readXML "/home/aki/.mixxx/mixxxbpmscheme.xml"
Debug: [Main]: BPM Scheme: "/home/aki/.mixxx/mixxxbpmscheme.xml" does not exist.
Debug: [Main]: getting midi device list, size 0 and: ""
Debug: [Main]: SoundManager::setupDevices()
Debug: [Main]: VinylControlProxy: Unknown vinyl type ""
Debug: [Main]: Defaulting to Serato...
Debug: [Main]: Building timecode lookup tables...
Allocating 2097152 slots (8192Kb) for 20 bit timecode (Serato 2nd Ed., side A)
Debug: [Main]: Starting vinyl control xwax thread
[New Thread 0xab5d6b70 (LWP 3435)]
Debug: [Main]: Building timecode lookup tables...
Allocating 2097152 slots (8192Kb) for 20 bit timecode (Serato 2nd Ed., side A)
Debug: [Main]: Starting vinyl control xwax thread
[New Thread 0xaa5d4b70 (LWP 3437)]
Debug: [Main]: SoundDevicePortAudio::open() "0, HDA Intel: Conexant Digital (hw:0,1)"
Debug: [Main]: m_dSampleRate 44100
Debug: [Main]: iLatencyMSec: 64
Debug: [Main]: output channels: 2 | input channels: 0
Debug: [Main]: iLatencySamples: 5644
Debug: [Main]: iLatencyMSec: 64
Debug: [Main]: Opening stream with id 0
Debug: [Main]: Opened PortAudio stream successfully... starting
Debug: [Main]: Dynamically loaded PortAudio library!
[New Thread 0xa9dd3b70 (LWP 3438)]
Debug: [Main]: PortAudio: Started stream successfully
Debug: [Main]: iNumDevicesOpenedForOutput: 1
Debug: [Main]: iNumDevicesOpenedForInput: 0
Debug: [Main]: TrackDAO::getTrack QThread(0x83e81e8, name = "Main") "qt_sql_default_connection"
Debug: [Main]: QSqlError(1, "Unable to execute statement", "no such table: Library")
Debug: [Main]: TrackDAO::getTrack QThread(0x83e81e8, name = "Main") "qt_sql_default_connection"
Debug: [Main]: QSqlError(1, "Unable to execute statement", "no such table: Library")
Debug: [Main]: Displaying mixxx
Debug: [Main]: Running Mixxx
Debug: [LibraryScanner 1]: QSqlError(-1, "Parameter count mismatch", "")
Debug: [LibraryScanner 1]: QSqlError(-1, "Parameter count mismatch", "")
Fatal: [LibraryScanner 1]: ASSERT: "trackLocationId >= 0" in file src/library/dao/trackdao.cpp, line 161

Program received signal SIGABRT, Aborted.
[Switching to Thread 0xadddbb70 (LWP 3431)]
0xb7fe2422 in __kernel_vsyscall ()
(gdb)

Thanks!

RJ Skerry-Ryan (rryan) wrote :

Could you remove ~/.mixxx again and give me a full copy of the log?

I recently added a schema.xml that the original schema is loaded from. If you haven't yet run `scons install' then it's possible that your binary can't find schema.xml.

rfcmedia (rfcmedia) wrote :

Did a fresh scons install, deleted ~/.mixxx. Doesn't work.
Then copied schema.xml manually to /opt/mixxx/share/mixxx and then it worked.
Looks like the default install doesn't install the schema.xml?

RJ Skerry-Ryan (rryan) wrote :

Ahh thanks for catching that. I just pushed revision 2351 which should fix that. Could you remove your schema.xml from /opt/mixxx/share/mixxx/ and then confirm that scons install copies schema.xml there?

Thanks again,
RJ

Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
importance: Undecided → High
status: New → Confirmed
milestone: none → 1.8.0
rfcmedia (rfcmedia) wrote :

Yup. scons copies schema.xml. Tested with r2355.

RJ Skerry-Ryan (rryan) wrote :

Great -- thanks!

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers