Some keyboard shortcuts don't work in branch 'features-sqlite'

Bug #501725 reported by RAFFI TEA on 2009-12-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
RJ Skerry-Ryan

Bug Description

In branch 'feature-sqlite' revision 2347:

If you load a track into one of the decks, it is not possible to start playing by using shortcut 'D' or 'L'.

All other shortcuts seem to work fine ,e.g., bass kill, ...

This has been tested on Windows 7 32 Bit using QT 4.6.

RJ Skerry-Ryan (rryan) wrote :

We may not get to this before the 1.8 beta, but we should look at it before the 1.8.0 release.

Thanks, Tobias

Changed in mixxx:
milestone: none → 1.8.0
RJ Skerry-Ryan (rryan) wrote :

Hey Tobias,

Can you verify this is still a problem and/or list your steps to reproduce? Here's what I tried:

1) Right click track in Library, load to player 1 (loading via pressing enter works too)
2) While focus is still in library pane, hit 'D' to start track playing.
3) Track starts playing.

This works for either D or L.

Thanks,
RJ

Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)

Hey RJ,

it is still a problem on my Windows system.

Steps to reproduce:
- Double click a track in the library which loads to player 1 or 2.
- Press D or L respectively

Expected behavior: The track should start playing
Observed behavior: Pressing D or L causes a kind of keyboard search in
the right splitter windows, i.e, in the ListView.

I hope this helps!

Tobias

Am 01.02.2010 17:15, schrieb RJ Ryan:
> Hey Tobias,
>
> Can you verify this is still a problem and/or list your steps to
> reproduce? Here's what I tried:
>
> 1) Right click track in Library, load to player 1 (loading via pressing enter works too)
> 2) While focus is still in library pane, hit 'D' to start track playing.
> 3) Track starts playing.
>
> This works for either D or L.
>
> Thanks,
> RJ
>
> ** Changed in: mixxx
> Assignee: (unassigned) => RJ Ryan (rryan)
>

RJ Skerry-Ryan (rryan) wrote :

Thanks Tobias,

I was able to reproduce this using beta1 in my Windows VM.

Changed in mixxx:
status: New → Confirmed
importance: Undecided → Low
RJ Skerry-Ryan (rryan) wrote :

This should be fixed in trunk now.

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released

Did anyone test this under OS X?

I see this behavior in Mixxx 1.9.0, OS 10.6 - !

jhno

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers