Missing columns in crate and playlist view

Bug #500474 reported by rfcmedia on 2009-12-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
RJ Skerry-Ryan

Bug Description

On Mixxx 1.8 branch features_sqlite r2338:

If I add songs to a playlist in a particular order, and then sort by a column, there's no way to go back to the original order that I put them there in without restarting Mixxx. One alternative is what banshee does -- when you click the column to sort them, they rotate through ascending, descending, and original order.

Also, after restarting Mixxx, the playlist is in the original order that I added them in, but the triangle/carat appears next to the column I sorted by, even though the list is not sorted.

But again, I don't think this is a very important bug. As long as you don't click the column. Thanks!

Related branches

RJ Skerry-Ryan (rryan) wrote :

Hey rfcmedia,

There is indeed a playlist-order column which you should be able to use to sort in the playlist-order. Unfortunately, due to a bug, certain columns in Playlist views and Crate views are mysteriously gone. I've renamed the bug to something that reflects this.

Changed in mixxx:
status: New → Confirmed
summary: - Unable to "unsort" list in playlist-view
+ Missing columns in crate and playlist view
RJ Skerry-Ryan (rryan) on 2009-12-26
Changed in mixxx:
milestone: none → 1.8.0
RJ Skerry-Ryan (rryan) wrote :
Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
importance: Undecided → Medium
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers