Searching for single-quote string fails in features_sqlite

Bug #500217 reported by rfcmedia on 2009-12-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
RJ Skerry-Ryan

Bug Description

Probably a quoting issue in SQL, but if you search your library from a song like "Let's Go" with a single-quote/apostrophe in it, the search fails, and disables the entire library search (the table column headers disappear)

Steps to reproduce.
1. Go to the search bar while looking at your library
2. Type "Let's" without the double quotes.

Expected behavior: either nothing shows up, or some songs show up.
Observed behavior: as soon as you type the apostrophe, the column headers (title, album, etc) disappear

And after that you cannot search or view your library anymore.

I think this is pretty critical, since many of songs have single quotes in them.

Related branches

RJ Skerry-Ryan (rryan) wrote :

Nice catch! I'll fix this soon.

Changed in mixxx:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → RJ Ryan (rryan)
milestone: none → 1.8.0
RJ Skerry-Ryan (rryan) wrote :
Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers