Relooping inconsistent conditional on current position

Bug #493557 reported by jus on 2009-12-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
RJ Skerry-Ryan

Bug Description

Intel OSX 10.5.8/ Mixxx features_sqlite branch

Load track to a Channel, play and set LoopIn and LoopOut.
While the track is looping hit Reloop, the current position will pass the Loop Out point just fine.
Agian hit Reloop, the track jump back in the loop at LoopIn. Thats how it should be.

But Reloop works only if your current position is past the the LoopOut.
It shows as active/inactive in the waveform overview but does actually nothing (until the current position reach LoopIn).

Reloop should jump in the loop even if the current position is before LoopIn.

RJ Skerry-Ryan (rryan) on 2010-01-05
Changed in mixxx:
assignee: nobody → RJ Ryan (rryan)
importance: Undecided → Low
status: New → Confirmed
milestone: none → 1.8.0
RJ Skerry-Ryan (rryan) wrote :

Just added a fix to trunk.

Changed in mixxx:
status: Confirmed → Fix Committed
jus (jus) wrote :

Tested with r2250, this bug may not fully solved.

1. Sound escapes loop , waveform display correctly not

Create a loop and let it loop. Click in the waveform OVERVIEW before the LoopIn.
You hear the song playing from the position you just clicked even if the waveform let you think you are in the Loop.

2. Jumping back into Loop works only if your current position is past the the LoopOut.

Create a loop, hit "reloop/exit" let the current play position pass Loop-out. Hit "reloop/exit" again , the current play position jump into the loop. Fine.

Now make sure you are not in the loop, click in the waveform OVERVIEW before the LoopIn. Hit "reloop/exit" and nothing happens ,the song just plays.
Hitting "reloop/exit" should jump in the loop even if the current position is before LoopIn.

RJ Skerry-Ryan (rryan) wrote :

Hey Jus -- thanks for the followup.

On #1

I'm not sure I can fix that for 1.8. There's a fix that I could do but I'm afraid that it would cause unforeseen problems so I'd rather wait until after.

On #2

That should not happen in r2250. I can't get the same to happen. When I am not in a loop and I skip to before the Loop-In with the waveform overview, then hit 'reloop', the deactivated loop activates and I seek directly into the beginning

RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers