SCS.3d play button fires cue sometimes

Bug #488596 reported by Albert Santoni on 2009-11-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Undecided
Unassigned
1.8
Undecided
Unassigned

Bug Description

If I load up a track and hit the play button on my SCS.3d about 25 times, Mixxx will sooner or later appear to interpret one of those button presses as a "cue" press and jump back to the cue point. I've confirmed that my SCS.3d is consistently sending the same note on/off messages for the play button with no deviations, and that Mixxx is receiving those correctly in our MIDI code (via --midiDebug).

I tried this with both the portmidi branch and trunk.

I've seen this as well, though it manifests as setting a new cue point if I press it repeatedly quickly.

Oh wait, try commenting line 341 in the SCS.3d script file (starts with if (currentlyPlaying ) and see if that makes the problem go away.

I can't reproduce this in the 1.8 branch r2452, so marking fixed. Please re-open if you can get it to happen again.

RJ Skerry-Ryan (rryan) on 2010-09-17
Changed in mixxx:
status: New → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers