Live broadcast to MP3 fails if soundsystem at 96000 (48000 = max for mpeg layer 3)

Bug #485226 reported by Navaho Gunleg on 2009-11-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mixxx
Low
RAFFI TEA

Bug Description

The EncoderMp3::initEncoder() routine adjusts LAME parameters to the samplerate that the sound system is running on.

For high samplerates and MP3 this causes tricky-to-trace issues because the maximum samplerate for mpeg layer 3 audio is 48000.

(Additionally, the "bitrate" parameter that is passed to this routine is completely ignored in this routine, which I suspect is a bug as well.)

The attached file solves these issues.

Hi Navaho,

What about if we just don't let you enable Shoutcast while running at
samplerates > 48000 Hz?

Can you whip up a QMessageBox call that gets fired when you try to
enable broadcasting?

Thanks,
Albert

On Thu, Nov 19, 2009 at 4:08 AM, Navaho Gunleg <email address hidden> wrote:
>
> ** Attachment added: "This patch seperates samplerate to samplerate_in and samplerate_out and sets LAME parameters accordingly."
>   http://launchpadlibrarian.net/35848589/encodermp3_samplerate.patch
>
> --
> Live broadcast to MP3 fails if soundsystem at 96000 (48000 = max for mpeg layer 3)
> https://bugs.launchpad.net/bugs/485226
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
>

RJ Skerry-Ryan (rryan) wrote :

Tobias,

Did you address this in your branch or is it not an issue? Can we close this?

Thanks,
RJ

Changed in mixxx:
assignee: nobody → RAFFI TEA (raffitea)
RAFFI TEA (raffitea) wrote :

I have not addressed this issue. All my test were at 44100 Hz. I am happy to see that other comunity members are interested in testing it.

Navaho Gunleg: did you use current trunk >= r2441 for testing?

I'll test the issue and report you back very soon!

RAFFI TEA (raffitea) wrote :

I was able to reproduce the bug.

Since the patch from Navaho Gunleg is not for current trunk (>= r2441) I adapted his changes in antoher patch, see attachment.

Basically, lame allows to specify input and ouput samplerates. If the input samplerate is greater than 48 Khz then the ouput samplerate is reduced to the maximum of 48 Khz. Downsampling is done by lame.

BTW, I observed same bug for Ogg streaming and recording. Unfortunately, you cannot specify different samplerates for input and output. Downsampling is what we have to do.

To conclude: The patch fixes the current bug. Ogg vorbis streaming, however, cause Mixxx to crash at 96 Khz. I have not the knowledge to implmenent downsampling algorithms to 48Khz and thus I recommend to add a Messagebox as Albert suggests. Does anyone agree?

Thanks for reporting this bug!

Changed in mixxx:
status: New → Confirmed
RAFFI TEA (raffitea) wrote :

<<< "Additionally, the "bitrate" parameter that is passed to this routine is completely ignored in this routine, which I <<<< suspect is a bug as well."

This has been addressed for a long time and is already in trunk.

RJ Skerry-Ryan (rryan) wrote :

Thanks guys! Committed the patch to trunk.

Changed in mixxx:
status: Confirmed → Fix Committed
jus (jus) wrote :

Cleanup, cant target a fix to already been published milestone.
Fix released in 1.9.0

Changed in mixxx:
status: Fix Committed → Fix Released
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers