Crash when loading low bitrate wav samples

Bug #443370 reported by Michael Z Freeman on 2009-10-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Critical
RJ Skerry-Ryan
1.10
Critical
RJ Skerry-Ryan
1.9
Critical
RJ Skerry-Ryan

Bug Description

Mixxx 1.7.0

Ubuntu Jaunty Jackolope with recommended older portaudio version.

Asus EeePC 701

Bit Rate, Sample Size, Channels, Sample Rate, Format

88kbps, 8bit, 1, 11khz, PCM

I confirmed that Mixxx crashes when loading these types of wav's. There may be other types but I could not confirm.

The crash takes place when I drag from the playlist to the the player. Mixxx crashes straight to the desktop. I could not find a log.

Related branches

This is interesting. Would you mind to try converting the file to AIFF and FLAC formats (keeping the specs the same) and see if you get the same crash?

RJ Skerry-Ryan (rryan) on 2010-10-15
tags: added: crash
RJ Skerry-Ryan (rryan) wrote :

Hey DJ_Barney,

Would you mind providing us with this problematic WAV file? You can upload it to the bug report or email it to me directly at <email address hidden>

Thanks,
RJ Ryan

jus (jus) on 2011-08-19
Changed in mixxx:
status: New → Incomplete

I confirmed the problem here after some tests. What crashes 1.9 is *MONO* sound samples. Low bitrate wav's and flac's DO play when they are stereo but I was loading mono versions of them. So maybe this bug report should be retitled or should I commit a new bug ?

Changed in mixxx:
status: Incomplete → Confirmed
RJ Skerry-Ryan (rryan) wrote :

Hey DJ_Barney -- cool to see you've made progress. Could you provide me with an example file that crashes Mixxx? That would help a lot in getting this bug fixed.

Changed in mixxx:
importance: Undecided → Critical
tags: added: wav

Here is an example. Once converted to a stereo wav the crash did not occur.

RJ Skerry-Ryan (rryan) wrote :

Hmm, can't reproduce with your WAV in the current 1.9 branch or on 1.9.0 on Mac OSX 10.6. 8 32-bit.

I'll try in Ubuntu later.

I can't reproduce either on 1.9 r2862 on Debian Squeeze/Stable with the provided WAV.

RJ Skerry-Ryan (rryan) wrote :

Reproduced:

1) Delete library
2) Drag file from #5 to the library (not to a deck)
3) divide by zero crash

This is a side-effect of the fix for Bug #753639 -- when the track is just ParseHeader()'d it is not open so no sndfile info is processed which results in a divide-by-zero. I fixed ParseHeader to initialize sndfile in that case and also guarded against future div-by-zero in that spot.

Changed in mixxx:
status: Confirmed → Fix Committed
assignee: nobody → RJ Ryan (rryan)
RJ Skerry-Ryan (rryan) wrote :

(clarification: step 2 is drag to library from OS file manager)

RJ Skerry-Ryan (rryan) on 2011-11-07
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments