Illegal instruction at first startup

Bug #430873 reported by joepurlings on 2009-09-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Medium
Albert Santoni

Bug Description

Just installed in Ubuntu 8.10 trough the deb file.

From first startup program hangs:

Debug: [Main]: Setting up plugin paths...
Debug: [Main]: ...done.
Debug: [Main]: Mixxx 1.7.0 "(svn 2505; built on: Aug 6 2009 @ 07:14:40) " is starting...
Debug: [Main]: No version number in configuration file. Setting to 1.7.0
Ongeldige instructie //dutch for illegal instruction

description: updated
RJ Skerry-Ryan (rryan) wrote :

Hi joepurlings,

What CPU do you have? Could you provide the output of `cat /proc/cpuinfo'?

Which deb did you download from mixxx.org?

Thanks,
RJ

Dear RJ,

Thanks for your quick answer!

Here is the output:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 8
model name : Pentium III (Coppermine)
stepping : 10
cpu MHz : 851.943
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse up
bogomips : 1705.98
clflush size : 32

I downloaded the latest version (1.7.0).

--
With kind regards,
Joep Urlings

Op woensdag 16-09-2009 om 17:53 uur [tijdzone +0000], schreef RJ Ryan:
> Hi joepurlings,
>
> What CPU do you have? Could you provide the output of `cat
> /proc/cpuinfo'?
>
> Which deb did you download from mixxx.org?
>
> Thanks,
> RJ
>

RJ Skerry-Ryan (rryan) wrote :

Hi again,

Can you list which .deb file you downloaded? There are actually two deb
files that you can download for Linux. When you click 'Linux' from the
downloads page you can either download:
http://downloads.mixxx.org/mixxx-1.7.0/mixxx-1.7.0-ubuntu-i386.deb
or
http://downloads.mixxx.org/mixxx-1.7.0/mixxx-1.7.0-ubuntu-amd64.deb

If you picked the amd64 one, then that's the reason because it is for an
AMD64 CPU and you have a Pentium 3. If you picked the i386 one, then we
must have goofed up and compiled that with too many optimizations. (e.g.
Pentium 3 doesn't have SSE2).

Thanks for reporting,
RJ Ryan

joepurlings (joepurlings) wrote :

Dear Ryan,

Again, thanks for your quick response.

Of course I used the i386 version.

--
With kind regards,
Joep Urlings

RJ Skerry-Ryan (rryan) wrote :

joepurlings wrote:
> Dear Ryan,
>
> Again, thanks for your quick response.
>
> Of course I used the i386 version.
>
>
Gotcha -- just had to check. It sounds like our debian packages are
using too many optimizations for i386. We probably compile SoundTouch
with SSE2 or something accidentally. That would be why you're getting
illegal instructions on your p3. Albert can you comment on what
optimizations we use for the debian packages? We should also look at our
P3 support on Windows.

Thanks,
RJ

Albert Santoni (gamegod) wrote :

On Thu, Sep 17, 2009 at 11:04 AM, RJ Ryan <email address hidden> wrote:
> joepurlings wrote:
>> Dear Ryan,
>>
>> Again, thanks for your quick response.
>>
>> Of course I used the i386 version.
>>
>>
> Gotcha -- just had to check. It sounds like our debian packages are
> using too many optimizations for i386. We probably compile SoundTouch
> with SSE2 or something accidentally. That would be why you're getting
> illegal instructions on your p3. Albert can you comment on what
> optimizations we use for the debian packages? We should also look at our
> P3 support on Windows.
>

We compile with optimize=2, which is supposed to be Pentium 4
optimizations. In my non-scientific testing, I thought there was a
fairly big difference between optimize=1 and 2 on my P4, so I opted to
make optimize=2 be used for our deb packages. (It was like 20 ms
difference in latency. That said, take all of this with a grain of
salt since I don't have any numbers to back me up. Also, our
cumulative experience has been that Linux is horribly inconsistent
with latency performance, it depends on a huge number of hardware and
software factors that nobody understands. It may have just been my
Linux box.)

Thanks,
Albert

joepurlings (joepurlings) wrote :

Hello Albert,

Thanks for your explaination.

Could you please help me to get a version that works at the PIII? I am
not very familiar with "compiling with options" in Linux yet.

I don´t need it to be quick like low latency and stuff, I´d just like a
stable and unbloated program.
--
With kind regards,
Joep Urlings

Albert Santoni (gamegod) wrote :

Hi Joep,

If you know how to open a terminal on Linux, you can hopefully manage to
follow our instructions on how to build Mixxx on Linux:
http://www.mixxx.org/wiki/doku.php/compiling_on_linux

These instructions walk you through the compilation process step-by-step
and should be fairly manageable for a user without tremendous compiling
experience.

Thanks,
Albert

On Fri, 2009-09-18 at 18:54 +0000, joepurlings wrote:
> Hello Albert,
>
> Thanks for your explaination.
>
> Could you please help me to get a version that works at the PIII? I am
> not very familiar with "compiling with options" in Linux yet.
>
> I don´t need it to be quick like low latency and stuff, I´d just like a
> stable and unbloated program.
> --
> With kind regards,
> Joep Urlings
>

joepurlings (joepurlings) wrote :

Hi Albert,

Okay, I will take a look at it as soon as I find some time.

I guess it will be okay then, I did some compiling before, but just don
´t have any experience using compiler options.

Thanks for looking after my problem. Concerning me, case can be closed.

--
With kind regards,
Joep Urlings

Op zondag 20-09-2009 om 23:12 uur [tijdzone +0000], schreef Albert
Santoni:
> Hi Joep,
>
> If you know how to open a terminal on Linux, you can hopefully manage to
> follow our instructions on how to build Mixxx on Linux:
> http://www.mixxx.org/wiki/doku.php/compiling_on_linux
>
> These instructions walk you through the compilation process step-by-step
> and should be fairly manageable for a user without tremendous compiling
> experience.
>
> Thanks,
> Albert
>
> On Fri, 2009-09-18 at 18:54 +0000, joepurlings wrote:
> > Hello Albert,
> >
> > Thanks for your explaination.
> >
> > Could you please help me to get a version that works at the PIII? I am
> > not very familiar with "compiling with options" in Linux yet.
> >
> > I don´t need it to be quick like low latency and stuff, I´d just like a
> > stable and unbloated program.
> > --
> > With kind regards,
> > Joep Urlings
> >
>

reetp (jcrisp) wrote :

Same error on Ubuntu 9.04

CPU / AMD Atlon XP2000+ - details as below

Downloaded & installed mixxx-1.7.0-ubuntu-i386.deb from site

mixxx
Debug: [Main]: Setting up plugin paths...
Debug: [Main]: ...done.
Debug: [Main]: Mixxx 1.7.0 "(svn 2505; built on: Aug 6 2009 @ 07:14:40) " is starting...
Debug: [Main]: Could not read "/home/user/.mixxx/mixxx.cfg"
Debug: [Main]: No version number in configuration file. Setting to 1.7.0
Illegal instruction

CPU
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 6
model name : AMD Athlon(tm) XP 2000+
stepping : 2
cpu MHz : 1662.470
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up
bogomips : 3324.94
clflush size : 32
power management: ts

Any suggestions ?????

ironstorm (ironstorm-gmail) wrote :

@reetp As per Albert's suggestion, why not try rebuilding from source - when you get to the part about optimization, selecting a CPU optimization level that matches the make of your CPU (http://www.mixxx.org/wiki/doku.php/compiling_on_linux#compile_and_install)

reetp (jcrisp) wrote :

Ironstorm,

Yes I probably can, but I guess that the principal is that if the package says -i386 then it should be compiled to run accordingly or instructions given that it can only run on processor X or Y or Z and if you want to optimise then compile your own.

Probably save a lot of bug reports ;-)

Personally I'm not overly experienced with compiling but looks like I'll have to try it.

So a decision-maker needs to decide if we will make sure to build for P-III and above, or build how we want and specify what the minimum CPU is to run the x86 package. Last I talked with anyone, the instructions were to build with only SSE optimization which excludes anything below Pentium III. (64-bit builds can have SSE2 because all x64 CPUs support it.)

Changed in mixxx:
assignee: nobody → Albert Santoni (gamegod)
importance: Undecided → Medium
milestone: none → 1.8.0
status: New → Confirmed
Albert Santoni (gamegod) wrote :

Yes, I think we should build our Mixxx.org packages with SSE, and make
that a minimum requirement for those packages. Athlon XP users will
have to compile from scratch. It's time to move forwards...

Albert

On Mon, May 17, 2010 at 5:52 AM, Pegasus <email address hidden> wrote:
> So a decision-maker needs to decide if we will make sure to build for
> P-III and above, or build how we want and specify what the minimum CPU
> is to run the x86 package. Last I talked with anyone, the instructions
> were to build with only SSE optimization which excludes anything below
> Pentium III. (64-bit builds can have SSE2 because all x64 CPUs support
> it.)
>
> ** Changed in: mixxx
>   Importance: Undecided => Medium
>
> ** Changed in: mixxx
>       Status: New => Confirmed
>
> ** Changed in: mixxx
>    Milestone: None => 1.8.0
>
> ** Changed in: mixxx
>     Assignee: (unassigned) => Albert Santoni (gamegod)
>
> --
> Illegal instruction at first startup
> https://bugs.launchpad.net/bugs/430873
> You received this bug notification because you are a member of Mixxx
> Development Team, which is subscribed to Mixxx.
>

Changed in mixxx:
status: Confirmed → Fix Committed
RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers