Hercules DJ Control Mp3 stops working after exactly 128 midi events

Bug #410750 reported by Groschi on 2009-08-08
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Sean M. Pappalardo

Bug Description

On my Win XP machine this problem occurs with versions 1.70 beta2 & final, beta1 works fine.
The device stops working after the first couple of knob-/fader-movements. In the log i can see, that this always happens after exactly 128 midi-events.
I tested the functionality of the device with "Midi Monitor" and everything works fine, so it's unlikely to be a hardware- or driver-problem.

Groschi (groschang) wrote :

Did you close Mixxx or does it quit on its own after 128 events?

And do you have another MIDI controller you can test with in Mixxx? (Even if it's a virtual keyboard or something.)
Are you using the 32 or 64-bit version of Mixxx?

Groschi (groschang) wrote :

Mixxx keeps running, only stops responding to the controller. Unfortunately i don't have another MIDI device to test with. I'm using the 32 bit version.

Have you perchance recently upgraded your Windows Hercules drivers? There's a release on 7/30/09: http://ts.hercules.com/eng/index.php?pg=view_files&gid=2&fid=28&pid=179&cid=1 Please try that, or if you already have that loaded, please try an earlier version. There may be a bug in the driver/firmware, since the SCS.3d and SCS.1m work fine in Windows on 1.7.0 and always have and these are all standard MIDI devices as far as Mixxx sees them.

ironstorm (ironstorm-gmail) wrote :

I just hammered Mixxx 1.7.0 on Windows XP w/ 3.HDJS.2009 drivers (the latest) and could not midi crap out after about 7 songs fiddling with just about every control pretty much continuously.

Can one of you with an MP3 try clearing the output mappings, close, reopen Mixxx and try again. No LEDs should light on the device but controls should still respond.

I'm wondering if this might be the same problem we had with sending too many updates to the outputs (this was a problem during the Linux driver development).

Groschi (groschang) wrote :

Ok, now i did a clean reinstall of the latest Hercules drivers (just to be sure...) and tested 1.7.0 and the two beta versions. Same thing as before: beta 1 works fine, the other versions behave as i described above. Deleting the output Mappings didn't help anything.
Btw, i noticed that version 1.70 also doesn't remember the Midi Mappings of the last session. Although it creates the "MixxxMIDIBindings.xml", i have to reload them manually every time. Again, this works fine for me in beta 1.
I haven't testet older hercules drivers yet but i'll try that as soon as possible.

Groschi (groschang) wrote :

I've tried it with an older driver (2008/4) now. Didn't help. :-(

Did you try removing the MIDI (led) outputs as I mentioned earlier?

On Sep 6, 2009 10:40 AM, "Groschi" <email address hidden> wrote:

I've tried it with an older driver (2008/4) now. Didn't help. :-(

-- Hercules DJ Control Mp3 stops working after exactly 128 midi events

Groschi (groschang) wrote :

Yup. I cleared the output mappings and saved the result as a new midi.xml file, because on my machine Mixxx 1.70 doesn't "remember" the mappings of the previous session (as i mentioned above, this still works in beta 1). Then is restarted Mixxx and loaded the new midi.xml with the empty output-table. Nothing changed.

Hi Groschi,

Thanks for continuing to work with us to troubleshoot this. Sean is
going to try to produce a test build for you using the Windows MIDI code
from beta1, to help us determine if that's where the problem is.

In the meantime, I've dug up the Herc Control MP3 mappings from beta 1
and beta 2:



Please try each one by placing it in your Mixxx/midi folder, starting
Mixxx, and then reloading your Hercules DJ Control MP3 mapping by
selecting it from the drop-down menu in the MIDI preferences. It's
possible that we just broke the mapping somehow, or that the changes in
the mapping are exposing some flaw in our code. This should help us
determine if either of those are the case.


Groschi (groschang) wrote :

Hey, actually i'm the one who has to thank you guys for working on this great software. :-)

I tried both files now. It didn't help.

Okay, please try the attached build and let us know how it goes.

Groschi (groschang) wrote :

It works. No more midi problems.

Groschi (groschang) wrote :

Also, the log looks a bit different...

1.70 says:
Debug: [Main]: Midi Device ' "Hercules DJ Control MP3 MIDI" ' found.
Debug: [Main]: Using MIDI Device # 0 : "Hercules DJ Control MP3 MIDI"
Debug: [Main]: Error: Unable to find requested MIDI output device "Hercules DJ Control MP3 MIDI"

test buld says:
Debug: [Main]: Midi Device ' "Hercules DJ Control MP3 MIDI" ' found.
Debug: [Main]: Using Midi Device # 0 : "Hercules DJ Control MP3 MIDI"
Debug: [MidiObject 1]: MidiMapping: Loading MIDI XML from "E:/Dokumente und Einstellungen/Administrator/Local Settings/Application Data/Mixxx/MixxxMIDIBindings.xml"
Debug: [MidiObject 1]: MidiOutputMappingTableModel::removeRows()
Debug: [MidiObject 1]: "Last used" settings found

Groschi (groschang) wrote :
Groschi (groschang) wrote :

Freaky stuff, man. Now try this build & let me know.

Groschi (groschang) wrote :

Doesn't work, shows the same behavior as in 1.70.
Also, like in 1.70, this build doesn't remember the midi mappings of the previous session. I forgot to mention that this worked in your previous test build with the old midi code.
The mixxxmidibindings.xml's created by both builds are identical.

This one oughta do it. Let me know.

Groschi (groschang) wrote :

It works.

Yay! Marking fixed in r2514. Thank you so much for your time on this, Groschi!!

So does the MP3 have any LEDs or other outputs? From the log, Mixxx is unable to see it as an output device too (Windows is not reporting it.)

Groschi (groschang) wrote :

Don't know, is it supposed to work as a midi output device?
At least the LEDs work with the bundled version of VirtualDJ, but i think that software doesn't communicate with the controller as a midi device, but as a game controller.
I've never seen any hint about the DJC MP3 as an output device, my system only sees an input device.
But maybe that's just a problem with my audio drivers, since the "Microsoft GS Wavetable SW Synth" (which is known to cause issues in many cases) is the standard midi output and i never found a way to disable it. I cannot disable just one single audio- or midi-device. If i disable one of them, all audio and midi devices (including the DJC MP3) get disabled automatically.

Groschi (groschang) wrote :

Ok, i found a hint in the hercules forums, that midi output doesn't work on windows generally. So i think mixxx is just telling the truth ;-)
Here's the post i'm talking about:

Changed in mixxx:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers