filenames with umlaut can not be loaded in player

Bug #409460 reported by Tango DJ on 2009-08-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mixxx
Low
Unassigned
1.7
Low
Unassigned
1.8
Low
Unassigned

Bug Description

XP 32bit, Win7 64bit and Mac OS-X, newest Mixxx version.

files with German and Spanish characters are shown in library but can not be played reliable.

example (win7, 64bit, Mixxx 1.7.0-beta1)
Air_Concret__(Electro)(Tango)__Bajofondo_Tango_Club__Supervielle__09.wav is OK.
En_mi,Soledad__(Electro)(Tango)____Bajofondo_Tango_Club__02.wav is PROBLEM.
Los_Tangueros__(Electro)(Tango)____Bajofondo_Tango_Club__03.wav is PROBLEM.

All are shown in library but only the Air... file can be loaded in the player.
I don't understand why Los_Tangueros is not loaded.
But when I rename the files those can be loaded nicely.

Tango DJ (tangomylove) on 2009-08-05
description: updated
description: updated
RJ Skerry-Ryan (rryan) wrote :

This is fixed in 1.8.0. Verified with these characters in a filename: 'äöü'

Changed in mixxx:
status: New → Fix Committed
importance: Undecided → Low

I have problems with a file that contains the '?' character. It's
probably related. I'll try with the latest 1.8 code and see if it's
fixed.

RJ Skerry-Ryan (rryan) on 2010-10-05
Changed in mixxx:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers